Bug 1676725 - Create ocp cluster panic with existing manifests
Summary: Create ocp cluster panic with existing manifests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Matthew Staebler
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-13 03:18 UTC by Qin Ping
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: creating the terraform to create the aws resources attempts to access fields that are not filled in when the master machines asset is read in from the state file Consequence: installer panics dereferencing a nil pointer Fix: properly acquire the needed data to create the terraform for the master machines Result: no installer panic when creating terraform
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description Qin Ping 2019-02-13 03:18:09 UTC
Description of problem:
Create ocp cluster panic with existing manifests

Version-Release number of the following components:
./openshift-install v4.0.0-0.171.0.0-dirty
RELEASE_IMAGE: 4.0.0-0.nightly-2019-02-12-150919
RHCOS: 47.313

How reproducible:
Always

Steps to Reproduce:
1. ./openshift-install create manifests --dir test
2. ./openshift-install create cluster --dir test
3.

Actual results:
Installation failed and returned error:
panic: interface conversion: runtime.Object is nil, not *v1alpha1.AWSMachineProviderConfig

Expected results:
Installation should be success.

Additional info:
$ ./openshift-install create cluster --dir test
WARNING Found override for ReleaseImage. Please be warned, this is not advised 
panic: interface conversion: runtime.Object is nil, not *v1alpha1.AWSMachineProviderConfig

goroutine 1 [running]:
github.com/openshift/installer/pkg/asset/cluster.(*TerraformVariables).Generate(0x863b450, 0xc420a03230, 0xc420cfd9f0, 0x2)
	/go/src/github.com/openshift/installer/pkg/asset/cluster/tfvars.go:109 +0x1398
github.com/openshift/installer/pkg/asset/store.(*storeImpl).fetch(0xc4207bf050, 0x51b5620, 0x863b450, 0x0, 0x0, 0x44df960, 0x4624240)
	/go/src/github.com/openshift/installer/pkg/asset/store/store.go:226 +0x7c0
github.com/openshift/installer/pkg/asset/store.(*storeImpl).Fetch(0xc4207bf050, 0x51b5620, 0x863b450, 0x51b5620, 0x863b450)
	/go/src/github.com/openshift/installer/pkg/asset/store/store.go:76 +0x4b
main.runTargetCmd.func1(0x7fff28afc1ef, 0x5, 0xc42040bee0, 0xc4208f3bf8)
	/go/src/github.com/openshift/installer/cmd/openshift-install/create.go:157 +0x13f
main.runTargetCmd.func2(0x8613960, 0xc42040bdc0, 0x0, 0x2)
	/go/src/github.com/openshift/installer/cmd/openshift-install/create.go:182 +0x81
github.com/openshift/installer/vendor/github.com/spf13/cobra.(*Command).execute(0x8613960, 0xc42040bd80, 0x2, 0x2, 0x8613960, 0xc42040bd80)
	/go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:766 +0x2c1
github.com/openshift/installer/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0xc420852780, 0x0, 0xc420853900, 0xc4208528d0)
	/go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:852 +0x30a
github.com/openshift/installer/vendor/github.com/spf13/cobra.(*Command).Execute(0xc420852780, 0xc4208f3eb8, 0x1)
	/go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:800 +0x2b
main.installerMain()
	/go/src/github.com/openshift/installer/cmd/openshift-install/main.go:56 +0x132
main.main()
	/go/src/github.com/openshift/installer/cmd/openshift-install/main.go:40 +0x9b

Comment 2 Matthew Staebler 2019-02-13 17:10:56 UTC
Fixed with https://github.com/openshift/installer/pull/1211

Comment 4 Qin Ping 2019-02-18 03:38:56 UTC
Verfied with:
$ ./openshift-install version
./openshift-install v4.0.0-0.175.0.0-dirty
RELEASE_IMAGE: 4.0.0-0.nightly-2019-02-17-182259
RHCOS: 47.318

Comment 5 W. Trevor King 2019-02-27 06:03:28 UTC
[1] went out with [2], so this should be fixed.

[1]: https://github.com/openshift/installer/pull/1211
[2]: https://github.com/openshift/installer/releases/tag/v0.13.0

Comment 8 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.