Bug 1676758 - [cloud] "oc get machine/machineset" doesn't work
Summary: [cloud] "oc get machine/machineset" doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jan Chaloupka
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-13 06:06 UTC by sunzhaohua
Modified: 2019-06-04 10:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description sunzhaohua 2019-02-13 06:06:20 UTC
Description of problem:
"oc get machine/machineset" doesn't work

Version-Release number of selected component (if applicable):
clusterversion: 4.0.0-0.nightly-2019-02-12-005016

How reproducible:
Always

Steps to Reproduce:
1. $ oc get machine or oc get machineset
2. $ oc get machines.machine.openshift.io -n openshift-machine-api
3. $ oc get machinesets.machine.openshift.io -n openshift-machine-api

Actual results:
"oc get machine/machineset" doesn't work. 

$ oc get machines
No resources found.

$ oc get machineset
No resources found.

$ oc get machinesets.machine.openshift.io -n openshift-machine-api
NAMESPACE               NAME                                   DESIRED   CURRENT   READY     AVAILABLE   AGE
openshift-machine-api   preserve-chaoyang5-worker-us-east-2a   1         1         1         1           18h
openshift-machine-api   preserve-chaoyang5-worker-us-east-2b   1         1         1         1           18h
openshift-machine-api   preserve-chaoyang5-worker-us-east-2c   1         1         1         1           18h

$ oc get machines.machine.openshift.io -n openshift-machine-api 
NAMESPACE               NAME                                         INSTANCE              STATE     TYPE        REGION      ZONE         AGE
openshift-machine-api   preserve-chaoyang5-master-0                  i-07aa58307d792df9e   running   m4.xlarge   us-east-2   us-east-2a   18h
openshift-machine-api   preserve-chaoyang5-master-1                  i-061abd8236a056b38   running   m4.xlarge   us-east-2   us-east-2b   18h
openshift-machine-api   preserve-chaoyang5-master-2                  i-032ba84b8a7fd0417   running   m4.xlarge   us-east-2   us-east-2c   18h
openshift-machine-api   preserve-chaoyang5-worker-us-east-2a-fk8s2   i-078fb1aabcefd6f63   running   m4.large    us-east-2   us-east-2a   18h
openshift-machine-api   preserve-chaoyang5-worker-us-east-2b-xrt6p   i-062401ea21551efa1   running   m4.large    us-east-2   us-east-2b   18h
openshift-machine-api   preserve-chaoyang5-worker-us-east-2c-s5lt7   i-044fb4238e6195bb9   running   m4.large    us-east-2   us-east-2c   18h

Expected results:
By default using "oc get machine" to check machines instead of using "oc get machines.machine.openshift.io".


Additional info:

Comment 1 Jan Chaloupka 2019-02-13 14:38:30 UTC
This is caused by presence of CRDs for both cluster.k8s.io and machine.openshift.io groups. We plan to remove cluster.k8s.io by the end of this week.

Comment 2 sunzhaohua 2019-02-18 03:49:02 UTC
Verified.

clusterversion: 4.0.0-0.nightly-2019-02-17-024922 

CRDs for cluster.k8s.io group have been removed.
$ oc get machine
NAME                             INSTANCE              STATE     TYPE        REGION      ZONE         AGE
zhsun3-master-0                  i-0a765236609bc5c5c   running   m4.xlarge   us-east-2   us-east-2a   39m
zhsun3-master-1                  i-0f11753514fe829a1   running   m4.xlarge   us-east-2   us-east-2b   39m
zhsun3-master-2                  i-017f621bd7be4c38b   running   m4.xlarge   us-east-2   us-east-2c   39m
zhsun3-worker-us-east-2a-trztc   i-018d9363972d254e4   running   m4.large    us-east-2   us-east-2a   38m
zhsun3-worker-us-east-2b-pc7sg   i-0d5c83fa360eaf0a2   running   m4.large    us-east-2   us-east-2b   38m
zhsun3-worker-us-east-2c-7tsk5   i-06723a5b82a2ad7ca   running   m4.large    us-east-2   us-east-2c   38m
$ oc get machineset
NAME                       DESIRED   CURRENT   READY     AVAILABLE   AGE
zhsun3-worker-us-east-2a   1         1         1         1           39m
zhsun3-worker-us-east-2b   1         1         1         1           39m
zhsun3-worker-us-east-2c   1         1         1         1           39m

Comment 5 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.