Bug 1676761 - No graph for memory utilization on the C & U utilization tab for the instances
Summary: No graph for memory utilization on the C & U utilization tab for the instances
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.11.0
Assignee: Robin Knaur
QA Contact: Nandini Chandra
Red Hat CloudForms Documentation
URL:
Whiteboard:
: 1579495 (view as bug list)
Depends On:
Blocks: 1679295 1683467 1683468
TreeView+ depends on / blocked
 
Reported: 2019-02-13 06:41 UTC by Rahul Chincholkar
Modified: 2019-12-13 15:09 UTC (History)
13 users (show)

Fixed In Version: 5.11.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1683467 1683468 (view as bug list)
Environment:
Last Closed: 2019-12-13 15:09:49 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Rahul Chincholkar 2019-02-13 06:41:30 UTC
Description of problem:

This bugzilla is raised in reference to https://bugzilla.redhat.com/show_bug.cgi?id=1552288

As of currently, this seems to be an issue with UI. We are collecting the AWS memory metrics since cfme version 5.9.2. However, there is an issue with memory utilization graph. 

We have reproduced this issue on our test environment and we could see the `mem_usage_absolute_average` values are captured in vmdb_production database, what we could not observe is the graph for memory utilization on the C & U utilization tab for the instances.
~~~
vmdb_production=# select timestamp, mem_usage_absolute_average from metrics where resource_name = 'rahulc-instance1';
      timestamp      | mem_usage_absolute_average 
---------------------+----------------------------
[...]
 2019-02-12 11:07:40 |           92.1889732715258
 2019-02-12 11:08:00 |           92.1889732715258
 2019-02-12 11:08:20 |           92.1889732715258
 2019-02-12 11:08:40 |           92.1889732715258
 2019-02-12 11:09:00 |           92.1889732715258
 2019-02-12 11:09:20 |           92.1889732715258
 2019-02-12 11:09:40 |           92.1889732715258
 2019-02-12 11:10:00 |           92.1889732715258
~~~


We can verify that the memory is there in rails as well:
~~~
pp Vm.find_by(:name=>"rahulc-instance1").metrics
 #<Metric:0x0000000012893228
  id: 69867,
  timestamp: Tue, 12 Feb 2019 15:50:00 UTC +00:00,
  capture_interval: 20,
  resource_type: "VmOrTemplate",
  resource_id: 96,
....
  mem_usage_absolute_average: 19.961337410001,
....
  created_on: Tue, 12 Feb 2019 15:55:26 UTC +00:00,
  derived_cpu_available: nil,
  derived_memory_available: 1024.0,
  derived_memory_used: 204.40409507841,
....
  derived_vm_used_disk_storage: 10737418240.0,
  derived_vm_allocated_disk_storage: 10737418240.0,
~~~


Version-Release number of selected component (if applicable):
5.9.4.7 

How reproducible:
Always

Actual results:
Memory Utilization Graph is not observed in C&U data

Expected results:
Memory Utilization Graph should be displayed in C&U data

Comment 1 Dave Johnson 2019-02-13 09:01:17 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Nandini Chandra 2019-02-14 18:44:17 UTC
Also, see https://bugzilla.redhat.com/show_bug.cgi?id=1579495

I'd reported the same issue through that BZ.

Comment 4 Nandini Chandra 2019-02-14 19:01:51 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1677406 

This one is for missing memory utilization graphs for ec2 Availability zones.

Comment 5 Harpreet Kataria 2019-02-19 02:42:59 UTC
*** Bug 1579495 has been marked as a duplicate of this bug. ***

Comment 18 CFME Bot 2019-02-26 13:16:15 UTC
New commit detected on ManageIQ/manageiq-providers-amazon/master:

https://github.com/ManageIQ/manageiq-providers-amazon/commit/434d92217cc3b07fe6ea7f58e6328294f09cdd49
commit 434d92217cc3b07fe6ea7f58e6328294f09cdd49
Author:     PanSpagetka <rknaur@redhat.com>
AuthorDate: Mon Feb 25 09:48:06 2019 -0500
Commit:     PanSpagetka <rknaur@redhat.com>
CommitDate: Mon Feb 25 09:48:06 2019 -0500

    Return true for memory_mb_available?
    https://bugzilla.redhat.com/show_bug.cgi?id=1676761

 app/models/manageiq/providers/amazon/cloud_manager/vm.rb | 4 +
 1 file changed, 4 insertions(+)

Comment 22 Nandini Chandra 2019-05-08 19:00:58 UTC
Verified in 5.11.0.2


Note You need to log in before you can comment on or make changes to this bug.