Binary RPMs built with rpm-3.0.5-9.6x have new dependencies which break
installation on older RPM systems:
error: failed dependencies:
rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by openssh-2.1.1p5-0.2
This is a real PITA as it forces users to upgrade to the latest rpm
release. IMO this is not good behavior for a minor release of RPM.
Please note that the existence of the rpmlib feature dependency is *not* the
problem. The rpmlib
is tracking versioned Prereq and Provides that are not supported in rpm-3.0.2
Remove versions from the Prereq: and Provides: in your package and the rpmlib
dependency will not be automagically generated.