Bug 16769 - rpm-3.0.5-9.6x break dependencies
Summary: rpm-3.0.5-9.6x break dependencies
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-23 01:18 UTC by Damien Miller
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 01:18:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damien Miller 2000-08-23 01:18:14 UTC
Binary RPMs built with rpm-3.0.5-9.6x have new dependencies which break
installation on older RPM systems:

error: failed dependencies:
	rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by openssh-2.1.1p5-0.2

This is a real PITA as it forces users to upgrade to the latest rpm
release. IMO this is not good behavior for a minor release of RPM.

Comment 1 Jeff Johnson 2000-08-24 15:19:43 UTC
Please note that the existence of the rpmlib feature dependency is *not* the
problem. The rpmlib
feature dependency
	rpmlib(VersionedDependencies)
is tracking versioned Prereq and Provides that are not supported in rpm-3.0.2
and earlier.
Remove versions from the Prereq: and Provides: in your package and the rpmlib
feature
dependency will not be automagically generated.


Note You need to log in before you can comment on or make changes to this bug.