Bug 16769 - rpm-3.0.5-9.6x break dependencies
rpm-3.0.5-9.6x break dependencies
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-08-22 21:18 EDT by Damien Miller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-22 21:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Damien Miller 2000-08-22 21:18:14 EDT
Binary RPMs built with rpm-3.0.5-9.6x have new dependencies which break
installation on older RPM systems:

error: failed dependencies:
	rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by openssh-2.1.1p5-0.2

This is a real PITA as it forces users to upgrade to the latest rpm
release. IMO this is not good behavior for a minor release of RPM.
Comment 1 Jeff Johnson 2000-08-24 11:19:43 EDT
Please note that the existence of the rpmlib feature dependency is *not* the
problem. The rpmlib
feature dependency
is tracking versioned Prereq and Provides that are not supported in rpm-3.0.2
and earlier.
Remove versions from the Prereq: and Provides: in your package and the rpmlib
dependency will not be automagically generated.

Note You need to log in before you can comment on or make changes to this bug.