Bug 1676979 - [abrt] ibus: switcher_run(): ibus-ui-gtk3 killed by SIGABRT
Summary: [abrt] ibus: switcher_run(): ibus-ui-gtk3 killed by SIGABRT
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e8dc3c2cd7f17bd89bfaa9344e2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-13 17:35 UTC by Bill Crawford
Modified: 2019-02-20 03:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 03:36:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (38.16 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: cgroup (365 bytes, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: core_backtrace (13.24 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: cpuinfo (971 bytes, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: dso_list (9.10 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: environ (640 bytes, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: limits (1.29 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: maps (64.54 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: mountinfo (3.72 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: open_fds (1019 bytes, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details
File: proc_pid_status (1.33 KB, text/plain)
2019-02-13 17:35 UTC, Bill Crawford
no flags Details

Description Bill Crawford 2019-02-13 17:35:16 UTC
Description of problem:
Tried to switch input methods. No response, pressed the keys again, still no response.

Shortly afterward, I noticed the key sequence was passing through to the application instead, suggesting that something had died.

Shortly after that, a notification popped up on my desktop telling me there was a "problem", and now I'm reporting it :o)

Version-Release number of selected component:
ibus-1.5.19-9.fc28

Additional info:
reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: switcher_run
executable:     /usr/libexec/ibus-ui-gtk3
journald_cursor: s=f3413bc266334e9ea0b150980e1bbb9c;i=20c6396;b=7c1591eb295643a598cfda43ac739135;m=1127c755b3a;t=581c9c920c26f;x=fe041f369a72bb89
kernel:         4.20.4-100.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1660521

Comment 1 Bill Crawford 2019-02-13 17:35:20 UTC
Created attachment 1534474 [details]
File: backtrace

Comment 2 Bill Crawford 2019-02-13 17:35:21 UTC
Created attachment 1534475 [details]
File: cgroup

Comment 3 Bill Crawford 2019-02-13 17:35:22 UTC
Created attachment 1534476 [details]
File: core_backtrace

Comment 4 Bill Crawford 2019-02-13 17:35:23 UTC
Created attachment 1534477 [details]
File: cpuinfo

Comment 5 Bill Crawford 2019-02-13 17:35:25 UTC
Created attachment 1534478 [details]
File: dso_list

Comment 6 Bill Crawford 2019-02-13 17:35:26 UTC
Created attachment 1534479 [details]
File: environ

Comment 7 Bill Crawford 2019-02-13 17:35:27 UTC
Created attachment 1534480 [details]
File: limits

Comment 8 Bill Crawford 2019-02-13 17:35:29 UTC
Created attachment 1534481 [details]
File: maps

Comment 9 Bill Crawford 2019-02-13 17:35:30 UTC
Created attachment 1534482 [details]
File: mountinfo

Comment 10 Bill Crawford 2019-02-13 17:35:31 UTC
Created attachment 1534483 [details]
File: open_fds

Comment 11 Bill Crawford 2019-02-13 17:35:32 UTC
Created attachment 1534484 [details]
File: proc_pid_status

Comment 12 fujiwara 2019-02-14 08:16:17 UTC
I need to check why the IMS switcher popup is not launched in your box.
Are you still able to reproduce the backtrace?

(In reply to Bill Crawford from comment #1)
> Created attachment 1534474 [details]
> File: backtrace

Comment 13 Bill Crawford 2019-02-19 20:17:56 UTC
I switched to fcitx because I didn't trust ibus after that :o)

If there are specific things I can do to test for you, I am willing to switch back for a while.

I could not understand the backtrace (there seemed to be multiple stack frames for the same function in the main thread).

Comment 14 fujiwara 2019-02-20 03:36:29 UTC
Right. The same backtrace means the same order of the functions.
If you still reproduce the same backtrace, please comment here.


Note You need to log in before you can comment on or make changes to this bug.