Bug 1677056 - default out of the box font rendering is virtually unreadable
Summary: default out of the box font rendering is virtually unreadable
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gsettings-desktop-schemas
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1678683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-13 21:58 UTC by Chris Murphy
Modified: 2019-02-25 08:46 UTC (History)
18 users (show)

Fixed In Version: gsettings-desktop-schemas-3.31.90-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-19 09:44:00 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of the problem (752.34 KB, image/png)
2019-02-13 21:59 UTC, Chris Murphy
no flags Details
20190201 compose (working) (54.66 KB, text/plain)
2019-02-19 04:05 UTC, Chris Murphy
no flags Details
20190201 compose (non-working) (54.24 KB, text/plain)
2019-02-19 04:10 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2019-02-13 21:58:21 UTC
Description of problem:

Recently, font rendering in Gnome Terminal is unusable.


Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-Rawhide-20190211.n.0.iso problem
gnome-terminal-3.30.2-2.fc30.x86_64
dejavu-fonts-common-2.35-8.fc30.noarch
dejavu-sans-fonts-2.35-8.fc30.noarch
dejavu-sans-mono-fonts-2.35-8.fc30.noarch
dejavu-serif-fonts-2.35-8.fc30.noarch

Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso noproblem
gnome-terminal-3.30.2-1.fc30.x86_64
dejavu-fonts-common-2.35-7.fc29.noarch
dejavu-serif-fonts-2.35-7.fc29.noarch
dejavu-sans-mono-fonts-2.35-7.fc29.noarch
dejavu-sans-fonts-2.35-7.fc29.noarch



How reproducible:
Always


Steps to Reproduce:
1. Boot Fedora-Workstation-Live-x86_64-Rawhide-20190211.n.0.iso in a VM
2.
3.

Actual results:

See screenshot, poorly rendered text out of the box.


Expected results:

Should look like Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso

Additional info:

If I start with Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso, and do a Gnome Software update to bring it up to date; the problem happens on the very next boot.

Regression testing has been limited. I can't reproduce the problem by only updating to

gnome-terminal-3.30.2-2.fc30.x86_64
dejavu-fonts-common-2.35-8.fc30.noarch
dejavu-sans-fonts-2.35-8.fc30.noarch
dejavu-sans-mono-fonts-2.35-8.fc30.noarch
dejavu-serif-fonts-2.35-8.fc30.noarch
gtk3-3.24.5-1.fc30.x86_64
clutter-gst3-3.0.27-1
clutter-gtk-1.8.4-5

The problem doesn't show up in Firefox, or Texedit.

[liveuser@localhost-live ~]$ fc-match monospace
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

If I manually change gnome terminal to use DejaVu Sans Mono of any size, the problem does not happen.

Not sure what else to test to narrow it down.

Comment 1 Chris Murphy 2019-02-13 21:59:07 UTC
Created attachment 1534576 [details]
screenshot of the problem

Comment 2 Christian Persch 2019-02-14 10:09:16 UTC
This shows you're using a proportional font instead of a monospace one; hence not a gnome-terminal problem but with your font configuration.

Comment 3 Chris Murphy 2019-02-14 17:44:49 UTC
(In reply to Christian Persch (GNOME) from comment #2)
> This shows you're using a proportional font instead of a monospace one;
> hence not a gnome-terminal problem but with your font configuration.

That doesn't tell me anything that helps progress or fix the bug.

1. The problem materializes just by doing updates. Was working on 20190201 and after updates it's broken. No change in configuration.
2. The problem happens out of the box just by booting LiveOS media and launching gnome-terminal.

So in any case it's not my font configuration, it is the default font configuration.

Comment 4 Kalev Lember 2019-02-18 17:09:29 UTC
I don't think it's a gnome-terminal problem but something going wrong with the fonts. Moving the ticket to fontconfig to loop in the relevant people.

Comment 5 Akira TAGOH 2019-02-19 03:43:00 UTC
No changes in fontconfig these days... maybe good to try fc-match monospace and see if both images makes any difference on results? also good to see what fonts were opened with cat /proc/`pidof gnome-terminal`/maps | grep fonts

Comment 6 Chris Murphy 2019-02-19 04:05:57 UTC
Created attachment 1536208 [details]
20190201 compose (working)

Requested information from the working environment, Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso

Comment 7 Chris Murphy 2019-02-19 04:10:10 UTC
Created attachment 1536209 [details]
20190201 compose (non-working)

This is the requested information from the non-working environment, Fedora-Workstation-Live-x86_64-Rawhide-20190211.n.0.iso

Comment 8 Chris Murphy 2019-02-19 04:15:07 UTC
gnome-terminal-3.30.2-1.fc30.x86_64
7fc02868e000-7fc0286cc000 r--p 00000000 fd:00 264766                     /usr/share/fonts/dejavu/DejaVuSansMono-BoldOblique.ttf
7fc0286cc000-7fc02870a000 r--p 00000000 fd:00 264767                     /usr/share/fonts/dejavu/DejaVuSansMono-Oblique.ttf
7fc02870a000-7fc02875b000 r--p 00000000 fd:00 264765                     /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf
7fc02875b000-7fc0287af000 r--p 00000000 fd:00 264768                     /usr/share/fonts/dejavu/DejaVuSansMono.ttf

gnome-terminal-3.30.2-2.fc30.x86_64
7fa6f9bfd000-7fa6f9c9a000 r--p 00000000 fd:00 264482                     /usr/share/fonts/dejavu/DejaVuSans-BoldOblique.ttf
7fa6f9c9a000-7fa6f9d35000 r--p 00000000 fd:00 264484                     /usr/share/fonts/dejavu/DejaVuSans-Oblique.ttf
7fa6f9d35000-7fa6f9de1000 r--p 00000000 fd:00 264481                     /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf
7fa6f9de1000-7fa6f9e9a000 r--p 00000000 fd:00 264485                     /usr/share/fonts/dejavu/DejaVuSans.ttf

fc-match monospace in both cases is 
[liveuser@localhost-live ~]$ fc-match monospace
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

Comment 9 Akira TAGOH 2019-02-19 08:54:39 UTC
The problem is that:

$ gsettings list-recursively | grep mono
org.gnome.Epiphany.web monospace-font 'Monospace 10'
org.gnome.desktop.interface monospace-font-name 'Source Code Pro 10'
$ fc-match "Source Code Pro 10"
DejaVuSans.ttf: "DejaVu Sans" "Book"

No Source Code Pro installed. if GNOME wants to make it default, they should have a dependency for that. this schema comes from gsettings-desktop-schemas. reassigning...

Comment 10 Kalev Lember 2019-02-19 09:26:55 UTC
Ahh, thanks for investigating!

Comment 11 Kalev Lember 2019-02-19 09:44:00 UTC
I added "Recommends: adobe-source-code-pro-fonts" in https://src.fedoraproject.org/rpms/gsettings-desktop-schemas/c/b04c5d9bf4d6a66f879c4fe9f9678a138b0d8b42?branch=master

Comment 12 Chris Murphy 2019-02-24 00:03:05 UTC
*** Bug 1678683 has been marked as a duplicate of this bug. ***

Comment 13 Nicolas Mailhot 2019-02-24 15:18:21 UTC
Please never require font packages by name, it can change over time, use the fonts() autoprovides computed by fontconfig at package build time


Note You need to log in before you can comment on or make changes to this bug.