Bug 167718 - kernel-debuginfo lacks kernel sources
kernel-debuginfo lacks kernel sources
Status: CLOSED DUPLICATE of bug 182681
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-09-07 12:11 EDT by Frank Ch. Eigler
Modified: 2013-03-06 00:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-18 15:25:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2005-09-07 12:11:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
While kernel-debuginfo includes some source code, it's not all.
In particular, it seems to pull in the sources belonging to .ko's in the kernel build, but not the sources for the vmlinux kernel itself.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Install kernel-debuginfo.
Look for a /vmlinux source file like "fs/open.c".

Actual Results:  Hang head low in disappointment.

Expected Results:  Raise hands in a hallelujah.

Additional info:

I believe some recent Fedora kernels fix this.
Maybe it's a rpmbuild packaging bug.
Comment 1 Jason Baron 2005-09-09 17:17:25 EDT
the source header for build kernel modules is in the -devel packaes
If you want the complete sources use the .src.rpm
Comment 2 Frank Ch. Eigler 2005-09-09 17:50:15 EDT
Perhaps you misunderstand the purpose of -debuginfo packages.  They are there to
enable source-level debugging of the binary RPMs, and include not just the DWARF
data pulled out of objects, but enough source code for (say) gdb to show
sufficient context.  Just about all -debuginfo packages include sources for this
reason.  Try it.

As I noted, the kernel-debuginfo file includes some sources, but not all.  That
is an inconsistency and a bug.
Comment 3 Jason Baron 2005-09-12 15:52:58 EDT
so you're saying the 'debuginfo' is missing for vmlinux but not for the modules?
Comment 4 Frank Ch. Eigler 2005-09-12 16:03:36 EDT
Almost.  The -debuginfo rpm contains generally *two* sets of things for
binaries: a snapshot of sources (from the BUILD/) directory, and the stripped
DWARF data extracted from the object files.  In the case of kernel-debuginfo,
both sets of information should be present, for the modules as well as the
kernel.  However, the sources are missing for the kernel.  The other "three
quarters" are there (DWARF+sources for modules, DWARF for kernel (/vmlinux file)).
Comment 6 Guy Streeter 2006-05-18 15:03:47 EDT
Did this get fixed by changing the rpm script?
If so, when did kernels start being built with the fix?
Comment 7 Jason Baron 2006-05-18 15:25:01 EDT
hmmm, bug 182681 seems to say this was implemented. however, i'm not sure if
this was changed in the build or if so, when. Since it seems like we are
duplicating efforts in the these two bugs...i'm closing this one as a dup of 182681.

*** This bug has been marked as a duplicate of 182681 ***

Note You need to log in before you can comment on or make changes to this bug.