Bug 1677209 - [RFE] - add support for cascade lake cpu to rhel7
Summary: [RFE] - add support for cascade lake cpu to rhel7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Denemark
QA Contact: jiyan
pashah
URL:
Whiteboard:
: 1674414 1758359 (view as bug list)
Depends On: 1674411 1760565 1760612
Blocks: 1678381 1693433 1745045 1749522
TreeView+ depends on / blocked
 
Reported: 2019-02-14 09:47 UTC by Jiri Denemark
Modified: 2020-01-10 06:06 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1678381 (view as bug list)
Environment:
Last Closed: 2019-11-18 09:13:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Denemark 2019-02-14 09:47:18 UTC
This bug was initially created as a copy of Bug #1674411

I am copying this bug because: 



Description of problem:
add support for cascade lake cpu to rhel7

Feature Description:
       Introduce new cpu model in qemu-kvm for Cascade platform.

       instructions detailed info, please ref https://software.intel.com/sites/default/files/managed/c5/15/architecture-instruction-set-extensions-programming-reference.pdf

Comment 1 Jiri Denemark 2019-02-14 09:49:46 UTC
*** Bug 1674414 has been marked as a duplicate of this bug. ***

Comment 3 Wang Xin 2019-03-25 07:56:05 UTC
Hi,

I found the patchset to support Cascadelake, and it seems to be ignored.
https://www.redhat.com/archives/libvir-list/2018-November/msg00967.html

Comment 4 Jiri Denemark 2019-04-08 08:50:11 UTC
Patch series adding Cascadelake CPU model and support for MSR features was
sent upstream for review:

https://www.redhat.com/archives/libvir-list/2019-April/msg00529.html

Comment 7 Jaroslav Suchanek 2019-08-05 11:51:26 UTC
This will be addressed in next major release of RHEL.

Comment 16 Eduardo Habkost 2019-10-04 13:32:08 UTC
*** Bug 1758359 has been marked as a duplicate of this bug. ***

Comment 17 Eduardo Habkost 2019-10-09 14:00:46 UTC
Adding Known Issue Doc Text, to make sure the consequences of not having arch-capabilities available are documented.

Comment 32 Jaroslav Suchanek 2019-11-18 09:13:02 UTC
Based on latest consensus customers will have to use cpu host-passthrough if they require Cascade-Lake capabilities. Closing for RHEL-7.


Note You need to log in before you can comment on or make changes to this bug.