Bug 1677214 - Email field should be an optional on Create Image Pull Secret page
Summary: Email field should be an optional on Create Image Pull Secret page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-14 09:58 UTC by XiaochuanWang
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Email field on Create Image Pull Secret page is required, even though email is not a required credential for any registry config. Consequence: User has to provide email on Create Image Pull Secret page even though it's not necessary. Fix: Removing the requirement to provide email when creating Image Pull Secret. Result: It's not necessary for the user to provide email when creating Image Pull Secret.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description XiaochuanWang 2019-02-14 09:58:49 UTC
Description of problem:
On Create Image Pull Secret page, email should not be a MUST, user can skip it to create the image secret.

Version-Release number of selected component (if applicable):
  4.0.0-0.nightly-2019-02-12-005016
console commits: a766235ee842ce3547c7e18c8fa92f194251d608

How reproducible:
Always

Steps to Reproduce:
1. Go to Secret -> Create Image Pull Secret 


Actual results:
Email is a MUST field.

Expected results:
Use does not need a valid email to create the image pull secret

Additional info:

Comment 1 Jakub Hadvig 2019-02-25 16:08:03 UTC
Fixing PR: https://github.com/openshift/console/pull/1186

Comment 2 XiaochuanWang 2019-02-27 05:40:42 UTC
The email field now is an optional. Created Image Pull secret successfully as below:
{"auths":{"docker.io":{"username":"xiaocwan","password":"bla","auth":"eGlhb2N3YW46Vml2aWFuLTEyMw==","email":""}}}

Verified on 4.0.0-0.nightly-2019-02-26-125216
Image: registry.svc.ci.openshift.org/ocp/release@sha256:ad591cc0d5654a14e3b722d0c7e538889900ea2c99f800597b9afb66c0be4ba0

Comment 5 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.