Bug 1677218 - RFE: support for extended PTP_SYS_OFFSET ioctl in chrony
Summary: RFE: support for extended PTP_SYS_OFFSET ioctl in chrony
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: chrony
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Miroslav Lichvar
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On: 1677215
Blocks: 1677213
TreeView+ depends on / blocked
 
Reported: 2019-02-14 10:02 UTC by Miroslav Lichvar
Modified: 2019-11-05 22:24 UTC (History)
6 users (show)

Fixed In Version: chrony-3.5-1.el8
Doc Type: No Doc Update
Doc Text:
Clone Of: 1643983
Environment:
Last Closed: 2019-11-05 22:24:17 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3589 None None None 2019-11-05 22:24:23 UTC

Description Miroslav Lichvar 2019-02-14 10:02:32 UTC
+++ This bug was initially created as a clone of Bug #1643983 +++

Description of problem:
A new ioctl is needed to enable a more accurate synchronization of the system clock with HW timestamping (bug #1643974). When available, the ioctl needs to be supported by chrony.

Version-Release number of selected component (if applicable):
chrony-3.2-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. run chronyd as an NTP client with HW timestamping and look for hwclock messages in the debug output:
    chronyd -d -d "server $LOCAL_NTPSERVER minpoll 2 maxpoll 2" \
       'hwtimestamp *' |& grep 'hwclock.*err='

Actual results:
2018-10-20T19:19:44Z hwclock.c:191:(HCL_AccumulateSample) HW clock samples=16 offset=-1.859570e-08 freq=2.936241e-05 raw_freq=3.643518e-05 err=1.193500e-06 ref_diff=7.251244e+03

It depends on the NIC, PCIe slot, and other things, but usually the reported error is about 0.7-2.5 microseconds.

Expected results:
Reported error smaller than 0.5 microsecond at least for some supported NICs.

Comment 7 errata-xmlrpc 2019-11-05 22:24:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3589


Note You need to log in before you can comment on or make changes to this bug.