Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1677246

Summary: ovirt-host-deploy-ansible fails on isolated (offline) nodes
Product: [oVirt] ovirt-engine-metrics Reporter: Simone Tiraboschi <stirabos>
Component: GenericAssignee: Shirly Radco <sradco>
Status: CLOSED CURRENTRELEASE QA Contact: Petr Matyáš <pmatyas>
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: bugs, christophe.godart, lleistne, mkalinin, sradco
Target Milestone: ovirt-4.3.3Flags: sradco: ovirt-4.3?
lleistne: testing_ack+
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-engine-metrics-1.2.1.3 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1685517 (view as bug list) Environment:
Last Closed: 2019-04-16 13:58:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Metrics RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1631193, 1685517    
Attachments:
Description Flags
ovirt-host-deploy-ansible none

Description Simone Tiraboschi 2019-02-14 11:07:06 UTC
Description of problem:
ovirt-host-deploy-ansible now fails on isolated hosts with:

2019-02-14 11:31:17,076 p=31991 u=ovirt |  TASK [oVirt.metrics/roles/oVirt.initial-validations : Check Rsyslog packages are available] ***
2019-02-14 11:31:18,119 p=31991 u=ovirt |  fatal: [c76he20190211h1]: FAILED! => {
    "changed": false
}

MSG:

Failure talking to yum: Cannot find a valid baseurl for repo: base/7/x86_64

2019-02-14 11:31:18,119 p=31991 u=ovirt |  ...ignoring
2019-02-14 11:31:18,158 p=31991 u=ovirt |  TASK [oVirt.metrics/roles/oVirt.initial-validations : Set logging_collector as rsyslog] ***
2019-02-14 11:31:18,191 p=31991 u=ovirt |  fatal: [c76he20190211h1]: FAILED! => {}

MSG:

The conditional check 'rsyslog_packages_availability.rc == 0' failed. The error was: error while evaluating conditional (rsyslog_packages_availability.rc == 0): 'dict object' has no attribute 'rc'

The error appears to have been in '/usr/share/ansible/roles/oVirt.metrics/roles/oVirt.initial-validations/tasks/main.yml': line 29, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Set logging_collector as rsyslog
  ^ here



Version-Release number of selected component (if applicable):
ovirt-host-deploy-common.noarch   1.8.0-0.0.master.20181220124603.git6a3fda8.el7
ovirt-engine.noarch               4.3.0.5-0.0.master.20190211194837.gitae3aa0e.el7


How reproducible:
100%

Steps to Reproduce:
1. Try to deploy an Internet insolated hosts where all the required packages are already there (do we miss something on ovirt-host ?)
2.
3.

Actual results:
Install failed with:
The conditional check 'rsyslog_packages_availability.rc == 0' failed. The error was: error while evaluating conditional (rsyslog_packages_availability.rc == 0): 'dict object' has no attribute 'rc'

Expected results:
it works even on disconnected hosts if all the packages are there

Additional info:

Comment 1 Simone Tiraboschi 2019-02-14 11:10:30 UTC
Created attachment 1534749 [details]
ovirt-host-deploy-ansible

Comment 2 Sandro Bonazzola 2019-02-14 11:27:29 UTC
/usr/share/ansible/roles/oVirt.metrics/roles/oVirt.initial-validations/tasks/main.yml is shipped by ovirt-engine-metrics

Comment 3 Shirly Radco 2019-03-06 06:39:16 UTC
As a workaround until this is fixed, oVirt.metrics role can be removed from the ovirt-host-deploy-ansible, if metrics store is not configured.

Comment 4 Sandro Bonazzola 2019-03-12 12:52:25 UTC
4.3.1 has been released, please re-target this bug as soon as possible.

Comment 6 Lucie Leistnerova 2019-03-28 15:02:59 UTC
Simone, please what are the exact verification steps here? We are not much familiar with isolated host deployment.

Comment 7 Simone Tiraboschi 2019-03-28 15:31:00 UTC
Simply deploy on an host with no Internet access

Comment 8 Petr Matyáš 2019-04-01 15:32:14 UTC
So I tried deploying HE on a host without access to the internet.

yum install ovirt-hosted-engine-setup ovirt-engine-appliance
ip route del default # so I'm unable to ping internet addresses (e.g. 8.8.8.8)
ovirt-hosted-engine-setup # which finished without problems

With information I got this was the correct scenario and thus putting verified on ovirt-engine-metrics-1.2.1.3-1.el7ev.noarch

Comment 9 Sandro Bonazzola 2019-04-16 13:58:19 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Comment 10 Sandro Bonazzola 2019-11-04 08:19:09 UTC
*** Bug 1763766 has been marked as a duplicate of this bug. ***