Bug 1677377 - Duplicate crd top level names in cluster.k8s.io and machine.openshift.io namespaces/groups - prevents use of short names
Summary: Duplicate crd top level names in cluster.k8s.io and machine.openshift.io name...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Jan Chaloupka
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-14 16:37 UTC by Mike Fiedler
Modified: 2019-06-04 10:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description Mike Fiedler 2019-02-14 16:37:56 UTC
Description of problem:

oc get crd | egrep "^machine" | awk {'print $1'}

machineclasses.cluster.k8s.io
machineclasses.machine.openshift.io
machinedeployments.cluster.k8s.io
machinedeployments.machine.openshift.io
machines.cluster.k8s.io
machines.machine.openshift.io
machinesets.cluster.k8s.io
machinesets.machine.openshift.io

Multiple types are replicated in two namespaces.   The cluster.k8s.io flavor never has any instances.   This makes commands like this impossible:

# oc get machines --all-namespaces
No resources found.



Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-02-12-150919


How reproducible: Always

Comment 1 Mike Fiedler 2019-02-14 16:38:40 UTC
Not sure RHCOS is the right component, did not see one for machine API - please re-route as needed.   Thanks.

Comment 3 Alberto 2019-02-15 11:06:16 UTC
This was an intermediate step of the API pivoting from cluster.k8s.io to machine.openshift.io
Finalised now by https://github.com/openshift/machine-api-operator/pull/208

Comment 4 Mike Fiedler 2019-02-15 14:16:22 UTC
Verified on 4.0.0-0.nightly-2019-02-15-034921 

oc get crd | grep machine | awk {'print $1'}

machineautoscalers.autoscaling.openshift.io
machineclasses.machine.openshift.io
machineconfigpools.machineconfiguration.openshift.io
machineconfigs.machineconfiguration.openshift.io
machinedeployments.machine.openshift.io
machinehealthchecks.healthchecking.openshift.io
machines.machine.openshift.io
machinesets.machine.openshift.io
mcoconfigs.machineconfiguration.openshift.io

Comment 7 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.