Bug 1677414 - sensors-detect version string displays 'sensors-detect revision $Revision$'
Summary: sensors-detect version string displays 'sensors-detect revision $Revision$'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: lm_sensors
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Ondřej Lysoněk
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks: 1755139 1741517 1743192
TreeView+ depends on / blocked
 
Reported: 2019-02-14 19:45 UTC by Rachel Sibley
Modified: 2020-04-28 16:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:43:51 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
spec file patch (734 bytes, patch)
2019-08-21 13:19 UTC, Ondřej Lysoněk
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Github lm-sensors/lm-sensors/commit/5c900c7e851cc1f0de81772432e37a54e9833f89 None None None 2020-05-04 09:25:06 UTC
Github lm-sensors/lm-sensors/commit/f1e1a7607caa96bda67920f76c795d1dc7d9a10c None None None 2020-05-04 09:25:06 UTC
Red Hat Product Errata RHBA-2020:1784 None None None 2020-04-28 16:43:59 UTC

Description Rachel Sibley 2019-02-14 19:45:18 UTC
Description of problem:
When you run sensors-detect the date and version are missing from the beginning output, instead you will see $REVISION$ displayed.

Version-Release number of selected component (if applicable):
lm_sensors-3.4.0-17.20180522git70f7e08.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run 'sensors-detect'
2.
3.

Actual results:
Something like 'sensors-detect revision 6170'

Expected results:
version string in replacement of $

Additional info:
See rhel7 bug https://bugzilla.redhat.com/show_bug.cgi?id=1362658

Comment 3 Ondřej Lysoněk 2019-08-21 13:19:47 UTC
Created attachment 1606517 [details]
spec file patch

Comment 8 Ondřej Lysoněk 2019-10-17 13:40:53 UTC
Upstream patch (the version string therein needs to be modified to 3.4.0):
https://github.com/lm-sensors/lm-sensors/commit/5c900c7e851cc1f0de81772432e37a54e9833f89

Comment 9 Ondřej Lysoněk 2019-10-17 14:23:57 UTC
Another upstream commit:
https://github.com/lm-sensors/lm-sensors/commit/f1e1a7607caa96bda67920f76c795d1dc7d9a10c

Comment 13 Rachel Sibley 2020-03-25 20:34:52 UTC
ALL TESTS PASSED

Verified version string is displayed properly now with latest lm_sensors build:

Before:
===========
root@ci-vm-10-0-137-171 ~]# rpm -q lm_sensors
lm_sensors-3.4.0-20.20180522git70f7e08.el8.x86_64

[root@ci-vm-10-0-137-171 ~]# sensors-detect
# sensors-detect revision $Revision$

After:
===========
[root@ci-vm-10-0-138-18 ~]# rpm -q lm_sensors
lm_sensors-3.4.0-21.20180522git70f7e08.el8.x86_64

[root@ci-vm-10-0-138-18 ~]# sensors-detect
# sensors-detect version 3.4.0+git

It differs from the fact that it doesn't display the entire release string as compared to RHEL7, but I don't see it 
as a blocker. I can file a separate BZ if necessary.

RHEL7 example:

~]# sensors-detect
# sensors-detect revision 3.4.0-4 (2016-06-01)

Comment 15 errata-xmlrpc 2020-04-28 16:43:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1784


Note You need to log in before you can comment on or make changes to this bug.