Bug 167750 - OOo export to xhtml produces empty files
OOo export to xhtml produces empty files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 16:12 EDT by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 04:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exported output from 1.9.128 with gcj as java (1.32 KB, application/xhtml+xml)
2005-09-08 04:25 EDT, Caolan McNamara
no flags Details
input document (5.76 KB, application/vnd.oasis.opendocument.text)
2005-09-08 04:26 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Sammy 2005-09-07 16:12:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.2 (like Gecko)

Description of problem:
Exporting any document from writer to xhtml produces empy documents. 
When the export is selected the progress bar properly loads as if things 
are working. The file is created but is empty. 

Version-Release number of selected component (if applicable):
openoffice.org-base-1.9.127-1.2.0.fc5

How reproducible:
Always

Steps to Reproduce:
1. Create a one line document in writer 
2. Choose export to xhtml 
3. Look at the resulting file 
   

Additional info:
Comment 1 Caolan McNamara 2005-09-08 04:25:21 EDT
Created attachment 118582 [details]
exported output from 1.9.128 with gcj as java
Comment 2 Caolan McNamara 2005-09-08 04:26:18 EDT
Created attachment 118583 [details]
input document
Comment 3 Caolan McNamara 2005-09-08 04:27:42 EDT
works for me, this is another java using process. If you're not using the fedora
provided java solution, perhaps this is the same problem as issue 164491
Comment 4 Sammy 2005-09-08 12:13:17 EDT
YES...the latest version (1.128-1.2.0) pulled in the gcj-compat rpms etc.
With these I see both JVM's under the options and choosing FSF results in
exporting xhtml correctly.

However, when I choose FSF all of the java macros under
 
Tools-->Macros-->Run-->OpenOffice Macros

do not show at all (only python ones show) e.g. WordCount macro. If I switch to
SUN Java they show up again.

Is this supposed to be that way because they are not ported to gcj yet?

Thanks

Note You need to log in before you can comment on or make changes to this bug.