Bug 1677524 - The community operator clusterlogging operator couldn't be installed
Summary: The community operator clusterlogging operator couldn't be installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-15 06:58 UTC by Anping Li
Modified: 2019-06-04 10:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
The pod logs in openshift-marketplace (70.65 KB, text/plain)
2019-02-18 14:30 UTC, Anping Li
no flags Details
CLM pod logs and install plan (16.40 KB, application/gzip)
2019-02-19 19:19 UTC, Mike Fiedler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:12 UTC

Description Anping Li 2019-02-15 06:58:22 UTC
Description of problem:
The clusterlogging operator couldn't be find after installed.

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-02-13-204401

How reproducible:
always

Steps to Reproduce:
1. Install clusterlogging from operator hub using global-operators group 
2. Check the clusterlogging in the installed Operators
3. check pod under openshift-operators namespaces


Actual results:
step2: 
2. The clusterlogging operator can't be found.
3. There isn't any pod under 

Expected results:

The clusterlogging operator are installed in openshift-operators namespace

Additional info:

Comment 1 Nick Hale 2019-02-15 15:43:46 UTC
This bug needs more info on your side. Please check for a subscription, csv, installplan, or any OLM resources created and their status.

Thanks, 

Nick

Comment 2 Nick Hale 2019-02-18 13:54:15 UTC
Requesting more info. See previous comment.

Comment 3 Anping Li 2019-02-18 14:29:31 UTC
The CSV couldn't be created.

$ oc get csv --all-namespaces
NAMESPACE                              NAME                   DISPLAY          VERSION   REPLACES   PHASE
openshift-operator-lifecycle-manager   packageserver.v0.8.1   Package Server   0.8.1                Succeeded
$ oc get subscription --all-namespaces
NAMESPACE                              NAME              PACKAGE           SOURCE                                 CHANNEL
openshift-operator-lifecycle-manager   packageserver     packageserver     olm-operators                          alpha
openshift-operators                    cluster-logging   cluster-logging   installed-community-global-operators   preview
$ oc get installplan --all-namespaces
NAMESPACE                              NAME            CSV                     SOURCE   APPROVAL    APPROVED
openshift-operator-lifecycle-manager   install-rkvj7   packageserver.v0.8.1             Automatic   true
openshift-operators                    install-5sc2z   clusterlogging.v0.0.1            Automatic   true

Comment 4 Anping Li 2019-02-18 14:30:46 UTC
Created attachment 1535989 [details]
The pod logs in openshift-marketplace

Comment 5 Nick Hale 2019-02-19 14:12:48 UTC
So the pod logs are for the catalog. It looks like an installplan was generated for the cluster-logging subscription which means that there (probably) wasn't an issue resolving the CSV or its dependencies. I need the pod logs from olm-operator and catalog-operator in openshift-operator-lifecycle-manager as well as the status of the installplan generated for clusterlogging in openshift-operators.

Comment 6 Mike Fiedler 2019-02-19 19:19:06 UTC
Created attachment 1536465 [details]
CLM pod logs and install plan

installplan resource
catalog-operator pod log
olm-operator pod log

Comment 7 Evan Cordell 2019-02-25 16:27:52 UTC
We've resolves some issues on the OLM side that should allow CLO to install now. Please try again with the latest release.

Comment 8 Anping Li 2019-02-26 07:17:53 UTC
@Evan, The logging can be deployed now. Could you move to on_qa?

Comment 9 Qiaoling Tang 2019-02-26 08:39:53 UTC
Verified in 4.0.0-0.nightly-2019-02-25-194625, the CLO and EO can be deployed.

Comment 12 errata-xmlrpc 2019-06-04 10:44:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.