Bug 1677574 - NFS failed to read and write on mounted dir
Summary: NFS failed to read and write on mounted dir
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-15 09:32 UTC by Wenqi He
Modified: 2019-06-04 10:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:12 UTC

Description Wenqi He 2019-02-15 09:32:56 UTC
Description of problem:
NFS volume failed read and write the mounted dir with next-gen installed OCP 4.0

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-02-13-204401   True        False         30h     Cluster version is 4.0.0-0.nightly-2019-02-13-204401

How reproducible:
Always

Steps to Reproduce:
1. Create NFS pv
2. Create pvc
3. Create a pod use this pvc

Actual results:

$ oc exec -it nfspod bash -n wehe
[root@nfspod /]# ls /mnt/
nfs
[root@nfspod /]# touch /mnt/nfs/wehe
touch: cannot touch '/mnt/nfs/wehe': Permission denied

Expected results:
$ oc exec -it nfspod bash -n wehe
[root@nfspod /]# ls /mnt/nfs/
[root@nfspod /]# touch /mnt/nfs/wehe
[root@nfspod /]# ls /mnt/nfs/
wehe


PV Dump:
$ oc get pv nfs -o yaml
apiVersion: v1
kind: PersistentVolume
metadata:
  annotations:
    pv.kubernetes.io/bound-by-controller: "yes"
  creationTimestamp: 2019-02-15T09:09:30Z
  finalizers:
  - kubernetes.io/pv-protection
  name: nfs
  resourceVersion: "1476721"
  selfLink: /api/v1/persistentvolumes/nfs
  uid: 66d6488b-3101-11e9-8f68-027bbb45b7ee
spec:
  accessModes:
  - ReadWriteMany
  capacity:
    storage: 1Gi
  claimRef:
    apiVersion: v1
    kind: PersistentVolumeClaim
    name: nfsc
    namespace: wehe
    resourceVersion: "1476718"
    uid: 6d0236dc-3101-11e9-914d-069e149c0ee4
  nfs:
    path: /
    server: 172.30.74.104
  persistentVolumeReclaimPolicy: Retain
status:
  phase: Bound


PVC Dump:
$ oc get pvc -o yaml -n wehe
apiVersion: v1
items:
- apiVersion: v1
  kind: PersistentVolumeClaim
  metadata:
    annotations:
      pv.kubernetes.io/bind-completed: "yes"
    creationTimestamp: 2019-02-15T09:09:40Z
    finalizers:
    - kubernetes.io/pvc-protection
    name: nfsc
    namespace: wehe
    resourceVersion: "1476893"
    selfLink: /api/v1/namespaces/wehe/persistentvolumeclaims/nfsc
    uid: 6d0236dc-3101-11e9-914d-069e149c0ee4
  spec:
    accessModes:
    - ReadWriteMany
    dataSource: null
    resources:
      requests:
        storage: 1Gi
    storageClassName: ""
    volumeName: nfs
  status:
    accessModes:
    - ReadWriteMany
    capacity:
      storage: 1Gi
    phase: Bound
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""


Additional info:

Comment 8 errata-xmlrpc 2019-06-04 10:44:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.