Bug 167765 - regression: connector does not remember passwords across sessions
regression: connector does not remember passwords across sessions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 17:39 EDT by bastiaan
Modified: 2008-03-10 02:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: evolution-exchange-2.12.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 02:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2005-09-07 17:39:49 EDT
Description of problem:
Has the feature 'remember this password'. However for exchange account this
appears to have been replaced with 'remember this password for this session'.
This in itself is already very annoying (and inconsistent because Evolution will
remember passwords for other mailbox type as long as you want).
But the problem is worse because Evolution appears to be very fragile in
situations where you have to enter a password while it tries to setup
connections to Exchange. This results in login failures with error message
'Could not locate server' !?  

Version-Release number of selected component (if applicable):
evolution-connector-2.3.8-1

How reproducible:
always

Steps to Reproduce:
1. setup an exchange account
2. get mail
3.
  
Actual results:
password popup box with option 'remember password for this session'

Expected results:
password popup box with option 'remember password'


Additional info:
Comment 1 Christian Krause 2006-06-02 09:58:10 EDT
It seems, that in FC5 the behaviour is the following:
1. password dialog has the option "remember password" (and _not_ "remember
password for this session" any more)
2. nevertheless evolution still asks on every startup for the password

I would suggest to update the bug to: 
  Version: FC5
  evolution-connector version: 2.6.1 (1.fc5.1)

Thx!
 
Comment 2 Matthew Barnes 2007-10-02 14:05:46 EDT
Is this problem still present in Fedora 8 Test 2 or later?
Comment 3 Christian Krause 2007-10-16 02:46:08 EDT
I've tested the recent version of F8 Test 3 and F7:
evolution-exchange-2.12.0-1.fc8
and
evolution-connector-2.10.3-1.fc7
and the problem is not present in both packages.
Comment 4 Matthew Barnes 2007-10-16 07:34:32 EDT
Thanks for responding.  Setting version to f8test3.
Comment 5 Matthew Barnes 2008-03-10 02:03:18 EDT
Misread comment #3.  Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.