Bug 167768 - consider upgradin sk98lin to a recent version
consider upgradin sk98lin to a recent version
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 17:57 EDT by Kaj J. Niemi
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 15:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jwltest-skge.patch (197.09 KB, patch)
2005-09-14 20:29 EDT, John W. Linville
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2005-09-07 17:57:55 EDT
Description of problem:
Please consider upgrading the sk98lin in RHEL4 (I guess for 4U3 now?) to a more
recent release.

Version-Release number of selected component (if applicable):
up to 4 U2 beta


Additional info:
As always, thanks :)
Comment 1 John W. Linville 2005-09-12 12:28:09 EDT
For various reasons, this will not be likely to happen. 
 
What device do you want supported?  Would you be interested in the skge and/or 
sky2 drivers? 
Comment 2 Kaj J. Niemi 2005-09-12 13:36:40 EDT
John,


I'm used sk98lin because that was what the installer (4U1) suggested. The GE 
chip is reported 88E8001 by lspci (vendor:device id is 11ab:4320)

On Shuttle SB83G systems (and others according to Marvell) the drivers supplied
by RHEL4 do not work properly - there are errors constantly printed in the
syslog and interface counters are always zero.

There been various discussions regarding the issue:

<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136158>
<http://bugzilla.kernel.org/show_bug.cgi?id=3598>

According to Marvell, version 8.24 of the sk98lin driver fixes the issue. I
applied it as a patch to the kernel*.src.rpm and it seems to compile cleanly. I
also enabled NAPI. I've got no trouble with it in the lab using both 4U1 and the
4U2 beta kernel while transfering data at high rates to/from the host.
 
As far as I could tell, there weren't any sk98lin affecting patches in the RHEL4
kernel with the exception of one (davej's MODULE_DEVICE_TABLE entry patch)

Please let me know if you need more information, thanks :)

Comment 3 John W. Linville 2005-09-14 20:29:59 EDT
Created attachment 118825 [details]
jwltest-skge.patch

Add the skge driver...
Comment 4 John W. Linville 2005-09-14 20:35:13 EDT
Test kernels with the above patch are available here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
These include the skge driver as an alternative to the sk98lin driver.  You 
may need to edit /etc/modprobe.conf and change instances of "sk98lin" to 
"skge" in order to use this driver.  Please give these kernels a try and post 
the results...thanks! 
Comment 5 John W. Linville 2005-10-03 16:34:07 EDT
Still could use some test results here... :-) 
Comment 6 Kaj J. Niemi 2005-10-19 18:05:39 EDT
Hi John,


I'm happy with the sk98lin driver. There haven't been any problems with it on
any of the systems requiring it. Is there something wrong with that particular
driver or is there another reason why you would prefer to switch to skge instead?

Thanks :)
Comment 7 John W. Linville 2005-10-20 11:06:09 EDT
The sk98lin driver has fallen out of favor with the Linux community and is 
essentially unmaintained.  While Marvell does have an update version available 
for download, the version in the Linux kernel (and in Fedora and RHEL) does 
not support a lot of newer variations of the hardware, particularly the 
Yukon-II chips. 
 
The sk98lin driver simply will not be updated in a Red Hat kernel unless/until 
the upstream sk98lin situation changes.  Even if I wanted to update it, I 
would be severely beaten by my peers... :-) 
 
If at all possible, please try the skge driver.  It should work with any 
hardware currently covered by the sk98lin driver.  Please post any test 
results (positive or negative) here...thanks! 
Comment 8 John W. Linville 2005-11-11 15:01:13 EST
Closed due to lack of response.  Please reopen when the skge and/or sky2 
testing results become available.  sk98lin will NOT be upgraded in RHEL4. 
Comment 9 Tom Sightler 2006-10-21 16:16:21 EDT
I'm not sure if you'll still take feedback here since you closed the bug, however, 
I recently purchased a DLink DGE-530T because is was the only card available at 
the one store in town and I was hoping it might work with RHEL4.

The system is RHEL4 U4 and it detected the card, and attempted to use the sky2 
driver, but this driver simply returned an error that the specific chip ID in 
question (0xB1) was not supported.  Further invesitgation turned up your pages 
with your test kernels and indicated the card should be supported with the skge 
driver.

I attempted to use your kernels, and modified the modprobe.conf to load the skge 
module instead of the sky2 module.  The 1.6 version of the skge module did 
recognize the card, and allowed me to bring the interface up, however, it would 
not pass any traffic.  The RX count on the interface would increase so it appeared 
to be receiving traffic, however, the TX count remained at zero.

I was able to get the card to work by downloading, complining, and installing the 
updated sk98lin driver from the http://www.syskonnect.de/ support website so I 
know the hardware is fine.  Actually performance seems quite good.

I attempted to compile a newer skge driver from the 2.6.19-pre2 kernels but there 
were too many changes and I didn't have time to attempt to hack it enough to 
compile.

Is there anything I can do to help with the testing effort or is this a lost 
cause?

Thanks,
Tom

Note You need to log in before you can comment on or make changes to this bug.