Bug 1677694 - bootstrap.py on RHEL5 gives SELinux alerts
Summary: bootstrap.py on RHEL5 gives SELinux alerts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Bootstrap
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Rich Jerrido
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-15 15:30 UTC by Stephen Wadeley
Modified: 2020-04-02 12:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 12:32:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
SELinux Alert info (178.68 KB, text/plain)
2019-02-15 15:30 UTC, Stephen Wadeley
no flags Details

Description Stephen Wadeley 2019-02-15 15:30:13 UTC
Created attachment 1535237 [details]
SELinux Alert info

Description of problem:

While testing bootstrap.py on RHEL5 SELinux alerts were seen.


Version-Release number of selected component (if applicable):

[root@rhel5 ~]# ./bootstrap.py --version
Foreman Bootstrap Script
This script is designed to register new systems or to migrate an existing system to a Foreman server with Katello
bootstrap.py 1.7.0


How reproducible:

every time I ran the script


Steps to Reproduce:
1. Add RHEL5 tools repo to an activation key
2. [root@rhel5 ~]# ./bootstrap.py -s sat6-5-rhel7-6.example.com -l admin -p RedHat1! -L "Default Location" -o "Default Organization" -g RHEL5-HG -a test_ak_rhel5 --force --skip katello-agent --skip puppet


Actual results:

see attached SELinux alert info

Expected results:

no SE Alerts

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=1564867#c8

Comment 3 Bryan Kearney 2020-03-04 14:08:08 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2020-04-02 12:32:27 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.