Bug 167787 - Update of tzdata package doesn't update the /etc/localtime
Summary: Update of tzdata package doesn't update the /etc/localtime
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tzdata   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-08 05:07 UTC by Ulrich Drepper
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 2.3.90-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 06:45:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Drepper 2005-09-08 05:07:28 UTC
Description of problem:
Ever since /etc/localtime ceased to be a symbolic link we have a problem with
updating the installed tiemzone dat ain /usr/share/zoneinfo.  Setting the
timezone copies one of these files to /etc/localtime but if the timezone data
gets updated the copy remains the same.  Updates don't take effect.

Version-Release number of selected component (if applicable):
every package so far

How reproducible:
always

Steps to Reproduce:
1.set timezone to use a file which is known to change after tzdata update
2.update package
3.observe /etc/localtime
  
Actual results:
hasn't changed

Expected results:
should correspond to new file version

Additional info:
This problem applies to all releases and FC.  We need to have a way for the
tzdata post-install code to determine what timezone the /etc/localtime file
corresponds to and then copy over the new file (if it changed).

Comment 1 Jakub Jelinek 2005-09-08 07:18:48 UTC
That's a big problem though.
1) tzdata %post can't use /bin/sh etc., as we'd get into a dependency loop
   (tzdata requiring shell, shell requiring glibc, glibc requiring glibc-common,
   glibc-common requiring tzdata)
2) statically linked proglet to do the update is not going to work either
   - tzdata is .noarch.rpm and rpm doesn't handle replacing a noarch package
   with arch specific one

I proposed years ago that system-config-date had a %trigger for this, but
I think its maintainer was strongly against that.

Comment 2 Jakub Jelinek 2005-09-13 06:45:12 UTC
glibc-common-2.3.90-12 in rawhide has /usr/sbin/tzdata-update proglet and
runs it both when glibc-common is upgraded/installed and as %trigger for
tzdata update.

Comment 3 Wade Mealing 2006-11-28 00:31:06 UTC
As of RHEL4 tzdata-2006m-3.el4, the tzdata package does automatically update the
time.  

I believe this bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.