This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 167793 - yum.Errors.RepoError happens when running up2date from command line
yum.Errors.RepoError happens when running up2date from command line
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 05:15 EDT by Allan Andersen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 11:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allan Andersen 2005-09-08 05:15:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
When I run up2date -uf, up2date --configure or any other up2date parameter I get the following error message:

An error has occurred:
yum.Errors.RepoError
See /var/log/up2date for more information

Here is the output from the log file.

-- /var/log/up2date begins --

[Day Mmm  d hh:mm:ss yyyy] up2date   File "/usr/sbin/up2date", line 1265, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 328, in main
    sources = sourcesConfig.getSources()
   File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 263, in getSources
    scfg = SourcesConfigFile(filename="/etc/sysconfig/rhn/sources")
   File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 42, in __init__
    self.load()
   File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 85, in load
    self.parseRepomd(line)
   File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 229, in parseRepomd
    repo.baseurlSetup()
   File "repos.py", line 544, in baseurlSetup
   File "repos.py", line 427, in check

-- /var/log/up2date ends --

I have tried several things already described in other bug reports regarding up2date:

 - I have changed line 162 (where it says 3 to 4) in file /usr/share/rhn/up2date_client/sourcesConfig.py
 - Hard coded $releasever to 4 in all .repo files in the directory /etc/yum.repos.d
 - Updated yum with test release yum-2.4.0-0.fc4

When I delete the .repo  files in directory /etc/yum.repos.d no errors are produced.

I have been able to update my computer with up2date -uf --nosig after a fresh installation, but at that time it produced weird messages in the terminal windows. For some reason, up2date is not working anymore. I don't think a fresh reinstall will solve my problem, I will probably end up in the same situation again, It's just a matter of up2date :O)

As others have noticed, my up2date agent (in kde) is not working either, buts that's another story.


Version-Release number of selected component (if applicable):
up2date-4.4.23-4

How reproducible:
Didn't try

Steps to Reproduce:
1. run up2date from a command line
2. Run up2date -uf --nosig
3.
  

Actual Results:  No updates are downloaded. Instead I get the following error:

An error has occurred:
yum.Errors.RepoError
See /var/log/up2date for more information

See log file output in the desctiption of this error report.

Expected Results:  A fresh, secured Windows box ;O)

Additional info:
Comment 1 Allan Andersen 2005-09-08 06:11:23 EDT
Just wamt to say that "yum update" works - maybe this can be used as a
workaround, until up2date works again.
Comment 2 Allan Andersen 2005-09-08 10:39:17 EDT
It turns out that I had problems with the proxy settings. I configured the proxy
seting with:

  up2date --configure

I didn't put http:// in front of the proxy url.

Please note that yum was working because I had set the HTTP_PROXY environment
variabel. Anyway, this issue should really be fixed anyway, the error nessage is
really bad.
Comment 3 Allan Andersen 2005-09-09 02:27:12 EDT
As it turns out, after some investigation, the error described above yields the 
same result, if:

  - your network is not running
  - wrong proxy settings
  - no network connection
  - etc.

You can be mislead to believe that it is the up2date command that doesn’t work 
properly and you don't see that it is yourself you have to blame. 
Comment 4 John Thacker 2006-10-29 15:21:49 EST
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.
Comment 5 John Thacker 2006-11-05 11:22:21 EST
Closing per previous message.

Note You need to log in before you can comment on or make changes to this bug.