Bug 167804 - smtpmail library fails to perform auth login
smtpmail library fails to perform auth login
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2005-09-08 08:48 EDT by Alberto Brizio
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 21.4-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-27 22:57:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alberto Brizio 2005-09-08 08:48:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
I need to send email using an Exchange server as my SMTP server rather than the local sendmail (or equivalent).

The smtpmail library for emacs is supposedly able to interface to an SMTP server that requires a LOGIN-type authentication (like the one I use), however I could not get it to work when using the smtpmail.elc part of emacs-common-21.4-5.

I got the latest revision of smtpmail.el from CVS (rev 1.77) and pointed emacs to that version rather than the byte-compiled one from the RPM and things work as expected, so I assume the problem to be with Fedora. I also randomly tried some older versions of the smtpmail.el (back to 1.68) and they work as well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Make sure your SMTP server _requires_ AUTH LOGIN
2. Configure your smtpmail-related parametes correctly in .emacs, e.g.:
(setq smtpmail-default-smtp-server "yoursmtpserver.example.com")
(load-library "smtpmail")
(setq message-send-mail-function 'smtpmail-send-it)
(setq smtpmail-auth-credentials
   '(("yoursmtpserver.example.com" 25 "username" "password")))
3. Turn on debugging in smtpmail library:
(setq smtpmail-debug-info 'enable)
4. Create an email message (C-x m with Gnus) and try sending it (C-c C-c)

Actual Results:  You receive an SMTP failure message, the debug trace shows that there was no attempt to perform authentication.

Expected Results:  The mail should be queued for delivery upon successful authentication with the SMTP server.

Additional info:
Comment 1 Jens Petersen 2005-09-08 20:45:14 EDT
I guess the version in emacs-21.4 is probably revision 1.51.

> I also randomly tried some older versions of the smtpmail.el (back to 1.68)
> and they work as well.

Ok, I guess the cvs version can be backported for FC5 at least, though
I'm naively hoping that Emacs 22 will be released by then...
Comment 2 Alberto Brizio 2005-09-09 12:17:09 EDT
Simon Josefsson suggested in an email that newer versions of smtpmail.el may
also require newer versions of sendmail.el (though that doesn't seem to be the
case for my issue), so keep that in mind if you end up backporting smtpmail.
Comment 3 Jens Petersen 2005-11-21 22:15:55 EST
The latest version of sendmail.el requires the variable hard-newline to be defined.
So I'll try just updating smtpmail.el for now.
Comment 4 Jens Petersen 2005-11-23 23:05:54 EST
I'm updating smtpmail in the next devel build.
Should be in emacs-21.4-9.
Comment 5 Jens Petersen 2006-03-27 22:57:25 EST
Fix should be in FC5.

Note You need to log in before you can comment on or make changes to this bug.