Bug 1678109 - EIPs required by installer does not honor master/work replica setting
Summary: EIPs required by installer does not honor master/work replica setting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Matthew Staebler
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-18 06:28 UTC by Johnny Liu
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:12 UTC

Description Johnny Liu 2019-02-18 06:28:26 UTC
Description of problem:
See the following details.

Version-Release number of the following components:
v4.0.0-0.175.0.0-dirty

How reproducible:
Always

Steps to Reproduce:
1. According to 4.0 doc, about "Resource Limits", installer 6 EIPs (Elastic IPs), one EIP per instances.
2. In my install, I change master to 1, and worker to 1 in install-config.yaml
3. Trigger install

Actual results:
Installer is still trying to create 6 EIPs, which lead to "AddressLimitExceeded" error.

Expected results:
Installer should respect the setting in install-config.yaml.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Matthew Staebler 2019-02-18 19:48:35 UTC
The number of EIPs created by the installer is based upon the number of availability zones in the region and not on the number of instances created. One EIP is created for each availability zone.

Comment 3 Johnny Liu 2019-02-19 02:17:48 UTC
(In reply to Matthew Staebler from comment #2)
> The number of EIPs created by the installer is based upon the number of
> availability zones in the region and not on the number of instances created.
> One EIP is created for each availability zone.

In my install, I am using us-east-1 region, the region has 3 availability zones, 1a, 1b, and 1c. According to your comments, installer should be create 3 EIPs, why it was still trying to 6 EIPs? am I wrong? 
Another questions out of this bug's scope, who would use these EIPs?

Comment 4 Johnny Liu 2019-02-19 02:26:08 UTC
After search EIPs via cluserID for a successful install, there is indeed have 3 EIPs created, why installer was creating 6 EIPs during installation.

Comment 5 Johnny Liu 2019-02-19 04:09:07 UTC
(In reply to Johnny Liu from comment #4)
> After search EIPs via cluserID for a successful install,
should be:
After search EIPs via cluserID for a successful install after switch over another region with higher limit.

Comment 6 Matthew Staebler 2019-02-19 13:04:26 UTC
> In my install, I am using us-east-1 region, the region has 3 availability zones, 1a, 1b, and 1c. According to your comments, installer should be create 3 EIPs, why it was still trying to 6 EIPs? am I wrong?

us-east-1 has 6 availability zones: us-east-1a, us-east-1b, us-east-1c, us-east-1d, us-east-1e, and us-east-1f.

Comment 7 Johnny Liu 2019-02-20 01:45:36 UTC
Who will use these IPs?
Why 6 EIPs are being created upon installation, but after install is completed, whey only 3 EIPs are left there?

Comment 8 Matthew Staebler 2019-02-20 01:58:00 UTC
(In reply to Johnny Liu from comment #7)
> Who will use these IPs?
> Why 6 EIPs are being created upon installation, but after install is
> completed, whey only 3 EIPs are left there?

That should not be happening. You saw this in us-east-1? From your comments, you said that there were 3 EIPs created when you used a different region.

Comment 9 Johnny Liu 2019-02-20 07:10:50 UTC
I selected 'us-east-2' region for a successful install, seem like the region only have 3 zones, which is different with 'us-east-1' region.

Just as what you said in comment 2, "One EIP is created for each availability zone". Is that an expected behavior? If yes, this issue beome a document bug.

Comment 10 Matthew Staebler 2019-02-20 12:48:13 UTC
Yes, that is the expected behavior: There is exactly one EIP created for each availability zone in the region.

Comment 11 Matthew Staebler 2019-02-22 20:48:14 UTC
The documentation [1] has been updated.

[1] https://docs.google.com/document/d/179C-pZH586oh21pUrJsmSCfVx5Uhn_josR1xdxRzJzo/edit#heading=h.sitnqy7qu1gj

Comment 16 errata-xmlrpc 2019-06-04 10:44:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.