Bug 1678159 - Should return to the secret detail page after cancelling edit secret
Summary: Should return to the secret detail page after cancelling edit secret
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-18 08:44 UTC by Yanping Zhang
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:12 UTC

Description Yanping Zhang 2019-02-18 08:44:01 UTC
Description of problem:
On one secret page, edit secret by "Actions"->"Edit Secret", then click "Cancel", it returns to secrets list page, but not the secret detail page.

Version-Release number of selected component (if applicable):
version   4.0.0-0.nightly-2019-02-17-182259
"io.openshift.build.commit.url": "https://github.com/openshift/console/commit/9bfcbc6e2f9a08a90207661dac14b11a6e99d1b8"

How reproducible:
Always

Steps to Reproduce:
1.On one secret page, edit secret by "Actions"->"Edit Secret", then click "Cancel".
2.
3.

Actual results:
1. It returns to secrets list page.

Expected results:
1. It should return to the secret detail page.

Additional info:

Comment 1 Jon Jackson 2019-02-18 20:27:06 UTC
https://github.com/openshift/console/pull/1196

Comment 3 Yanping Zhang 2019-03-18 08:23:02 UTC
4.0.0-0.nightly-2019-03-15-063749
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6404040e21341e57fd0df4ed79acc66441284e75bb08468ecb0e9fa9ac15c2bb
io.openshift.build.commit.url=https://github.com/openshift/console/commit/d850084dde5c6816a22faf94adb5ad7346a245ad
Checked on ocp 4.0 env with above version, clicking cancel button when edit secret will jump back to secret list now.
The bug has been fixed, so move it to Verified.

Comment 4 Yanping Zhang 2019-03-18 08:24:41 UTC
(In reply to Yanping Zhang from comment #3)
> 4.0.0-0.nightly-2019-03-15-063749
> quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:
> 6404040e21341e57fd0df4ed79acc66441284e75bb08468ecb0e9fa9ac15c2bb
> io.openshift.build.commit.url=https://github.com/openshift/console/commit/
> d850084dde5c6816a22faf94adb5ad7346a245ad
> Checked on ocp 4.0 env with above version, clicking cancel button when edit
> secret will jump back to secret list now.
Sorry, clicking cancel button when edit secret will jump back to secret detail page now.
> The bug has been fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2019-06-04 10:44:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.