Bug 167816 - unable to get rid of resize_inode ext3 feature
unable to get rid of resize_inode ext3 feature
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Jay Turner
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-09-08 10:11 EDT by Karsten Hopp
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0060
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:12:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for tune2fs (446 bytes, patch)
2005-10-04 06:21 EDT, Thomas Woerner
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2005-09-08 10:11:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
It is currently not possible to mount ext3 filesystems created be RHEL-4 on RHEL-3 installations due to 'unsupported feature resize_inode'. But our current e2fsprogs
don't allow removal of that feature with tune2fs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mke2fs on RHEL4
2. try to mount the newly created filesystem on RHEL-3
3. try to get rid of resize_inode with tune2fs -O^resize_inode
  

Actual Results:  removal of resize_inode feature impossible

Additional info:

the only solution at the moment is to reformat the filesystem
Comment 1 Stephen Tweedie 2005-09-08 10:35:20 EDT
Works for me.  I just made a filesystem with e2fsprogs from RHEL-4 U2, and
mounted on RHEL-3 on a 2.4.21-32.EL kernel.  And RHEL-3 can see the resize_inode
flag set:

# tune2fs -l /dev/hdb
tune2fs 1.32 (09-Nov-2002)
...
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal resize_inode filetype sparse_super
...

As a tune2fs workaround for now, I think "debugfs" (performed from the RHEL-4
box) should work: 

$ debugfs -w /dev/$FOO
debugfs:  feature -resize_inode
^D

then e2fsck -fy /dev/$FOO to clean up the metadata.
use the command "feature -resize_inode".

But that still doesn't explain why your fs did not mount.
Comment 2 Thomas Woerner 2005-10-04 06:21:52 EDT
Created attachment 119582 [details]
Patch for tune2fs

Here is a patch for tune2fs to enable creation and removal of the resize_inode
feature. Is is essential to check the filesystem with e2fsck afterwards,
because the 'real' changes to the filesystem are not done by tune2fs.

The patch is in the actual FC 3, 4 and devel trees.
Comment 6 Red Hat Bugzilla 2006-03-07 13:12:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0060.html
Comment 7 Eric Sandeen 2008-02-29 11:45:15 EST
For posterity:  e2fsprogs-1.40.7 has integrated this change.

Note You need to log in before you can comment on or make changes to this bug.