Bug 1678200
| Summary: | Q35: Cloned VM with Q35 chipset, failed to run (PCI controller model is null instead of pcie-root). | ||||||||
|---|---|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Nisim Simsolo <nsimsolo> | ||||||
| Component: | BLL.Virt | Assignee: | Shmuel Melamud <smelamud> | ||||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Nisim Simsolo <nsimsolo> | ||||||
| Severity: | medium | Docs Contact: | |||||||
| Priority: | unspecified | ||||||||
| Version: | 4.3.0 | CC: | bugs, michal.skrivanek, nsimsolo, rbarry | ||||||
| Target Milestone: | ovirt-4.3.2 | Flags: | aoconnor:
ovirt-4.3+
|
||||||
| Target Release: | --- | ||||||||
| Hardware: | Unspecified | ||||||||
| OS: | Unspecified | ||||||||
| Whiteboard: | |||||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||||
| Doc Text: | Story Points: | --- | |||||||
| Clone Of: | Environment: | ||||||||
| Last Closed: | 2019-03-26 07:20:49 UTC | Type: | Bug | ||||||
| Regression: | --- | Mount Type: | --- | ||||||
| Documentation: | --- | CRM: | |||||||
| Verified Versions: | Category: | --- | |||||||
| oVirt Team: | Virt | RHEL 7.3 requirements from Atomic Host: | |||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||
| Embargoed: | |||||||||
| Attachments: |
|
||||||||
Created attachment 1535876 [details]
vdsm.log.xz
Created attachment 1535877 [details]
engine.log.xz
Verified upstream: ovirt-engine-4.3.2.1-0.0.master.20190310172919.git0b3fbad.el7 vdsm-4.40.0-59.git5533158.el7.x86_64 libvirt-client-4.5.0-10.el7_6.4.x86_64 qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64 Michal I see this has been already verified in 4.3.2, can you please check current target milestone and status of the bug? Verified: ovirt-engine-4.4.0-0.0.master.20190318180517.git576124b.el7 vdsm-4.40.0-96.gite291014.el7.x86_64 libvirt-client-4.5.0-10.el7_6.6.x86_64 qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64 This bugzilla is included in oVirt 4.3.2 release, published on March 19th 2019. Since the problem described in this bug report should be resolved in oVirt 4.3.2 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |
Description of problem: Trying to run clone of VM with Q35 chipset, failed with the next vdsm.log ERROR: 2019-02-18 11:50:01,444+0200 ERROR (vm/e86855af) [virt.vm] (vmId='e86855af-8a46-4f6a-bd4d-b4000d7dbdba') The vm start process failed (vm:937) Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 866, in _startUnderlyingVm self._run() File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 2852, in _run dom = self._connection.defineXML(self._domain.xml) File "/usr/lib/python2.7/site-packages/vdsm/common/libvirtconnection.py", line 131, in wrapper ret = f(*args, **kwargs) File "/usr/lib/python2.7/site-packages/vdsm/common/function.py", line 94, in wrapper return func(inst, *args, **kwargs) File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3733, in defineXML if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self) libvirtError: XML error: The PCI controller with index='0' must be model='pcie-root' for this machine type, but model='(null)' was found instead Issue is relevant only for clones of VM with Q35 chipset with UEFI BIOS/secure boot. Version-Release number of selected component (if applicable): ovirt-engine-4.3.0.5-0.0.master.20190207124642.git415c7e8.el7.noarch vdsm-4.30.8-58.git60c5a6d.el7.x86_64 qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64 libvirt-client-4.5.0-10.el7_6.4.x86_64 How reproducible: 100% Steps to Reproduce: 1. create clone of VM with Q35 chipset and UEFI BIOS. 2. Try to run cloned VM. 3. Actual results: Cloned VM failed to start. Expected results: Cloned VM should run. Additional info: vdsm.log and engine.log attached.