Bug 167831 - Do not link libtiff to libstdc++
Do not link libtiff to libstdc++
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtiff (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 13:29 EDT by dann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann 2005-09-08 13:29:07 EDT
Description of problem:
libtiff.so is linked to libstdc++
(try ldd /usr/lib/libtiff.so)

applications that link to libtiff (like for example emacs) then are also linked
to libstdc++ and must suffer a little performance penalty on startup and have an
extra 700KB+ mapping at runtime. 

The only reason this is done is because of 2 little functions:
extern  TIFF* TIFFStreamOpen(const char*, std::ostream *);
extern  TIFF* TIFFStreamOpen(const char*, std::istream *);

AFAICT (at least on my FC4 installation) nothing uses the above 2 functions. 

It might be a better idea to put these 2 functions in a separate library
libtiffxx so that all the C applications that use libtiff don't have to be
linked to libstdc++. This is not a binary compatible change though.

There is a --disable-c++ flag that disables adding the c++ functions to libtiff.so

Version-Release number of selected component (if applicable):
libtiff-3.7.1-6
Comment 1 dann 2005-09-11 12:13:48 EDT
It looks like this issue has been solve upstream starting with tiff-3.7.2

tiff-3.7.3/ChangeLog says: 

2005-01-11  Andrey Kiselev  <dron@remotesensing.org>
[snip]

        * libtiff/Makefile.am: Place the C++ stream API in the separate
        library called libtiffxx to avoid unneeded dependencies. Probably
        there will be more C++ API in the future. As per bugs

        http://bugzilla.remotesensing.org/show_bug.cgi?id=733

        and

        http://bugzilla.remotesensing.org/show_bug.cgi?id=730
Comment 2 Matthias Clasen 2005-09-29 15:22:18 EDT
Not worth an FC4 update, fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.