Bug 1678569 - Several R packages started failing in koschei rebuilds with openblas-0.3.5-3
Summary: Several R packages started failing in koschei rebuilds with openblas-0.3.5-3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openblas
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-19 06:20 UTC by Mattias Ellert
Modified: 2019-03-11 20:19 UTC (History)
3 users (show)

Fixed In Version: openblas-0.3.5-5.fc29 openblas-0.3.5-5.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 00:51:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github xianyi OpenBLAS issues 2009 None None None 2019-02-25 07:14:53 UTC

Description Mattias Ellert 2019-02-19 06:20:55 UTC
Description of problem:

After the update to readline 8 several R packages started failing in koschei.
Only the x86_64 build is failing. The aarch64 and ppc64le builds are OK.

Version-Release number of selected component (if applicable):

https://apps.fedoraproject.org/koschei/package/R-ape
https://apps.fedoraproject.org/koschei/package/R-data.table
https://apps.fedoraproject.org/koschei/package/R-diffobj
https://apps.fedoraproject.org/koschei/package/R-formatR
https://apps.fedoraproject.org/koschei/package/R-gamlss.dist
https://apps.fedoraproject.org/koschei/package/R-microbenchmark
https://apps.fedoraproject.org/koschei/package/R-qtl
https://apps.fedoraproject.org/koschei/package/R-rlang

Steps to Reproduce:
1. Rebuild one of the failing packages in rawhide/F30

Actual results:

Failed build

Expected results:

Successful build

Comment 1 Mattias Ellert 2019-02-20 08:45:59 UTC
More of the same. Koschei rebuilds that started to fail on x86_64 but still succeeding on aarch64 and ppc64le.

https://apps.fedoraproject.org/koschei/package/R-gee
https://apps.fedoraproject.org/koschei/package/R-gss
https://apps.fedoraproject.org/koschei/package/R-plyr
https://apps.fedoraproject.org/koschei/package/R-poLCA
https://apps.fedoraproject.org/koschei/package/R-reshape2
https://apps.fedoraproject.org/koschei/package/R-Rmpfr

The following are noarch packages where the koschei rebuild started to fail. The build were attempted on an x86_64 machine. So the cause might be the same. 

https://apps.fedoraproject.org/koschei/package/R-gplots
https://apps.fedoraproject.org/koschei/package/R-sfsmisc

Comment 2 Elliott Sales de Andrade 2019-02-25 06:42:23 UTC
Since I cannot reproduce locally due to an outdated mirror and/or no Rawhide compose, I had a small set of packages to test against to see which is problematic. These failures are not caused by the readline bump, but by openblas-Rblas-0.3.5-3, which contains several newly-backported patches.

Comment 3 Elliott Sales de Andrade 2019-02-25 07:14:54 UTC
It looks more likely that it's not the patches per se, but rather that the previous openblas was built gcc8 and the patches fixing gcc9 were incomplete. So I'll link the upstream bug report for the original FTBFS here.

Comment 4 Mattias Ellert 2019-02-28 10:41:57 UTC
Now that koschei has started to do rawhide build again after the F30 branching, we can see that the latest changes to openblas in rawhide (openblas-0.3.5-5.fc31) make several packages build again.

E.g. octave and scipy:

https://apps.fedoraproject.org/koschei/package/octave
https://apps.fedoraproject.org/koschei/package/scipy

Most of the R packages listed above have not yet been rebuild in rawhide by koschei since koschei started doing rawhide builds again, but I kicked of them by giving it a big manual priority and this one built fine in koschei rawhide:

https://apps.fedoraproject.org/koschei/package/R-qtl

hopefully the others will work too once koschei is processing its queue.

However, all these package still fail in Fedora 30 which still has openblas-0.3.5-3.fc30.

Could the openblas maintainers consider merging the changes from rawhide (openblas-0.3.5-5.fc31) back into f30 and do a Fedora 30 build with the latest set of patches, so that things will work equally well there?

Comment 5 Fedora Update System 2019-02-28 16:31:41 UTC
openblas-0.3.5-5.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a457d910b

Comment 6 Fedora Update System 2019-02-28 16:31:48 UTC
openblas-0.3.5-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b7573e497f

Comment 7 Fedora Update System 2019-03-01 03:35:59 UTC
openblas-0.3.5-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9a457d910b

Comment 8 Fedora Update System 2019-03-01 22:23:17 UTC
openblas-0.3.5-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b7573e497f

Comment 9 Fedora Update System 2019-03-04 00:51:45 UTC
openblas-0.3.5-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-03-11 20:19:58 UTC
openblas-0.3.5-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.