Bug 167860 - File descriptor 3 left open
File descriptor 3 left open
Status: CLOSED DUPLICATE of bug 156873
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-08 19:54 EDT by Ronald Cole
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 16:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2005-09-08 19:54:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.7.10-1.1.3.1

Description of problem:
After a fresh install of RHEL 4ES Update 1 with LVM, every reboot disturbingly complains "File descriptor 3 left open" twice before starting init.

Version-Release number of selected component (if applicable):
lvm2-2.01.08-1.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
On a Tyan S2676 with dual 3.6G Xeons, I configured four 73G U320 SCSI drives with two on channel A and two on channel B.  I configured the first and third drives with two partitions: /dev/md0 as /boot in a RAID 1, and /dev/md1 as a LVM PV in a RAID 1.  I then configured the second and fourth drives with one partition: /dev/md2 as a LVM PV in a RAID 1.  I then configured both LVM PV partitions as Logical Group 00 and created ten Logical Volumes on it and performed an "everything" install and swapped discs until I was instructed to reboot.

Actual Results:  Upon reboot, the system paused for well over a minute after printing the nash version and then printed:

File descriptor 3 left open
  Reading all physical volumes.  This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
File descriptor 3 left open
  10 logical volume(s) in volume group "VolGroup00" now active
INIT: version 2.85 booting

And so it complains upon each reboot!

Expected Results:  All opened files to be closed and therefore no warning messages at all about leaking file descriptors being found and closed.

Additional info:
Comment 1 Suzanne Hillman 2005-09-09 16:08:21 EDT

*** This bug has been marked as a duplicate of 156873 ***
Comment 2 Ronald Cole 2005-09-09 17:37:08 EDT
<doh>
Oh, good.  You closed this lvm2 bug as a duplicate of a grub bug.  I just
grepped the grub sources and the telltail "File descriptor N left open" string
was nowhere to be found.  I look forward to the grub errata that fixes this problem!
</doh>

Note You need to log in before you can comment on or make changes to this bug.