Bug 167877 - Squirrelmail and UTF-8 errors
Squirrelmail and UTF-8 errors
Status: CLOSED DUPLICATE of bug 162852
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Depends On:
  Show dependency treegraph
Reported: 2005-09-09 02:19 EDT by jørgen nørgaard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-09 18:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jørgen nørgaard 2005-09-09 02:19:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
Full user names encoded in UTF-8 (default on the system) is not encoded correctly by squirrelmail.

It becomes something like:

"From: Jørgen Nørgaard <jnp@ifs.dk>"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Make sure fedora is using UTF-8 (LANG=UTF-8 ?)
2. Create user name with for example '�' in full name
3. Send mail via squirrelmail on this system to this system.
4. read the mail with squirrelmail

Actual Results:  Full name of sender is inserted UTF-8 encoded.

Squirrelmail, however, when reading the mail does interpret full sender name properly. Some clients do
interpret reasonably, though probably using guess work part of the way.

Expected Results:  Either convert full name to iso-8859 (or what ever the webserver uses) or encode the mail header so it will 
be decoded or use a heuristic to detect encoding used.

Additional info:
Comment 1 jørgen nørgaard 2005-09-09 02:22:36 EDT
The '?' in step 2 should be 'ø' (decimal 216 in iso8859-1, &oslash;)
Comment 2 Warren Togami 2005-09-09 18:29:59 EDT

*** This bug has been marked as a duplicate of 162852 ***

Note You need to log in before you can comment on or make changes to this bug.