Bug 1678906 - [marketplace] Updates in remote registry does not get pulled down
Summary: [marketplace] Updates in remote registry does not get pulled down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: aravindh
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-19 20:50 UTC by Abu Kashem
Modified: 2019-06-04 10:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Moving to grpc CatalogSources introduced this issue where if there are new updates for existing operators on Quay but no new operators were added or removed, the updates won't get picked up Consequence: Updates to operators in Quay don't get pulled down to the cluster Fix: Always scale the registry pod deployment down and back up to ensure the updates are picked up instead of just updating the deployment spec. Result: Updates are pulled down from Quay to the cluster.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:20 UTC

Description Abu Kashem 2019-02-19 20:50:08 UTC
Steps to Reproduce:
- Create a custom operator source in quay where you can push updates.
- Create an OperatorSource object that points to the above.
- Wait until the OperatorSource object is reconciled successfully.
- Now Create a new CatalogSourceConfig Object that specifies a package from the above OperatorSource object.
- Wait until the CatalogSourceConfig is reconciled successfully.
- Push an update to quay for the specified package in the above CatalogSourceConfig object.
- Wait for an hour for the changes to be detected. Watch marketplace logs to check whether changes have been detected.

Actual Result:
- The registry pod associated with CatalogSourceConfig does not get killed and recreated. 

Expected Result:
- The registry pod associated with CatalogSourceConfig should get killed. The new pod instance should download the new version of the package specified.

Comment 1 Fan Jia 2019-02-20 06:11:36 UTC
> Expected Result:
> - The registry pod associated with CatalogSourceConfig should get killed.
> The new pod instance should download the new version of the package

all the registry pod associated with the installed catalogsourceconfig and the catalogsourceconfig that created by yaml file manually won't be updated until you edit them.
test env:

4.0.0-0.nightly-2019-02-19-024716

Comment 3 Fan Jia 2019-02-26 08:33:30 UTC
env
clusterversion:4.0.0-0.nightly-2019-02-25-234632

sometimes the csc will update automatically
sometime the csc won't be updated even you modified the packages in the config yaml. maybe the reason: (https://bugzilla.redhat.com/show_bug.cgi?id=1679309)
will test after the bug(https://bugzilla.redhat.com/show_bug.cgi?id=1679309) is fix

Comment 5 Fan Jia 2019-02-28 06:18:56 UTC
1.testenv:
clusterversion: 4.0.0-0.nightly-2019-02-27-213933
marketplace image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:db3741fada8ffb0417e20b58781d2028a17c2c7697c0965b248b6af8501ef312

2. csc wil update automatically after Updates in remote registry.

Comment 8 errata-xmlrpc 2019-06-04 10:44:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.