Bug 167896 - Unable to unmount a local file system exported by NFS
Unable to unmount a local file system exported by NFS
Status: CLOSED DUPLICATE of bug 167636
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 05:23 EDT by Bruno Cornec
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 16:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Cornec 2005-09-09 05:23:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.6

Description of problem:
When trying to unmount a file system which is exported by NFS to a large number of heterogeneous clients, the unmounting is denied:

umount: /d1: device is busy

/var/log/messages contains the following traces at the time of the umount:

Aug 31 08:24:36 ganlxsr3 rpc.statd[921]: Received erroneous SM_UNMON
request from ganlxsr3 for 193.x.y.z
Aug 31 08:24:36 ganlxsr3 kernel: lockd: couldn't shutdown host module!

No processs seem to be using that filesystem at the moment we tried to unmount it:

# lsof | grep d1
#

Gives nothing.

The problem we also see related to that issue, is that the [lockd] daemon which is now running correctly wasn't there in the list of process

# ps auxww | grep lockd
#
Gives nothing



Version-Release number of selected component (if applicable):
kernel 2.4.21-32.0.1.ELsmp

How reproducible:
Sometimes

Steps to Reproduce:
1. Wait a sufficient amount of time (some days/weeks)
2. unexport /d1
3. try to umount /d1
4. buzy message as above
  

Actual Results:  file system remains mounted

Expected Results:  file system should have been unmounted without error

Additional info:
Comment 1 Bruno Cornec 2005-09-09 12:39:06 EDT

*** This bug has been marked as a duplicate of 167636 ***
Comment 2 Ernie Petrides 2005-09-09 16:22:29 EDT
Reopening/reclosing to fix assignee.
Comment 3 Ernie Petrides 2005-09-09 16:29:32 EDT
Apparently an accidental duplicate report.

*** This bug has been marked as a duplicate of 167636 ***

Note You need to log in before you can comment on or make changes to this bug.