Bug 167904 - Upgrade request rrdtool to 1.2
Upgrade request rrdtool to 1.2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
http://people.ee.ethz.ch/~oetiker/web...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 07:38 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 17:30:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-09-09 07:38:46 EDT
Can rrdtool please be upgraded to the 1.2.11 release?  This is a major release
upgrade from the 1.0 series, but is backward compatible.

More details of what is new are in
http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/newin12.txt

Some changes will be required to the rpm spec file, but the one included in the
tarball is probably a good start.
Comment 1 Matthias Saou 2005-11-22 06:49:33 EST
Sorry for the late reply.
Last I had checked 1.2, the PHP module was still broken, thus forcing the
upgrade on people depending on that module would cause some pain... Do you
happen to know if the PHP module now works in recent versions (like 1.2.11)?
Comment 2 Reuben Farrelly 2005-11-22 22:56:18 EST
The future for php-rrdtool looks pretty bleak:

* Only cursory mention of php-rrdtool in the specfile in the tarball
* Does not exist in Dag Wieers repo http://dag.wieers.com/packages/rrdtool/ -
note that he has current rrdtool rpms but none of the v1.2 ones have
php-rrdtool.  Not to suggest that that is the authorative source of RPMs but the
fact it isn't there is significant IMHO.
* Mandrake have removed it from their distro as it won't build.  Looks like
debian don't do it either anymore (I think).
* Relatively few recent postings about it in google

So looks like it's not going to be coming back soon unless someone who really
wants it can be bothered resurrecting it (and no one has stepped up yet).

Perhaps it is time to think about obsoleting rrdtool 1.0 and the php-rrdtool
rpm, and marking this in in the release notes for FC5 as obsoleted package, and
removing it totally for FC6+.  Something like rrdtool10-1.0.49 and
php-rrdtool10-1.0.49 as well as rrdtool-1.2, so that for now those users who
need it can still get it.

Could you just upgrade the core rrdtool package in -devel, and run with both the
old obsoleted 1.0 version with php-rrdtool, as well as version 1.2?
Comment 3 Jose Pedro Oliveira 2005-11-23 13:21:03 EST
rrdtool/cgilib problems:

1) rrdtool version 1.2.x no longer includes the cgilib library in the tarball.  
   It now needs to be packaged separately.

2) last official cgilib version : v0.5
   See references [1] and  [2]

3) last unofficial (?) cgilib version : v0.5.2
   See references [3] and [4]


References:

[1] cgilib homepage
  http://www.infodrom.org/projects/cgilib/

[2] cgilib 0.5 download
  http://www.infodrom.org/projects/cgilib/download/cgilib-0.5.tar.gz
  http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/libs/cgilib-0.5.tar.gz

[3] [rrd-developers] cgilib-0.5.1.tar.gz
  http://lists.ee.ethz.ch/rrd-developers/msg01620.html

[4] [rrd-developers] Re: cgilib-0.5.1.tar.gz
  http://lists.ee.ethz.ch/rrd-developers/msg01621.html
  http://lists.ee.ethz.ch/p/cgilib-0.5.2.tar.gz

Comment 4 Reuben Farrelly 2006-01-30 18:46:05 EST
A patch/tarball which seems to contain the required pieces to build php-rrdtool
with rrdtool 1.2 is at
http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/contrib/

The php_rrdtool.txt file in the directory says that "I've installed this in PHP4
and PHP5, rrdtool-1.0.49, 1.0.50, 1.2.6, 1.2.7, 1.2.11 all worked without any
issues."

Hopefully that's the last piece required to allow for a build of rrdtool-1.2 and
the additional php-rrdtool...

Comment 5 Duncan Innes 2006-02-06 17:22:26 EST
Any ideas when he 1.2 series might be able to be released into Fedora Extras?

I've been waiting for what seems like AGES for 1.2 rpm's.

What are the thoughts on the other RRD packages?  perl-rrdtool and
python-rrdtool (tcl too I suppose, but that's not my bag)

Duncan
Comment 6 Jose Pedro Oliveira 2006-06-05 17:30:27 EDT
Jarod Wilson has just updated the devel branch to version 1.2.13 (and the FC-5
to version 1.0.50).  rrdtool 1.2.13 should appear in the mirrors soonish (next
push).

rrdtool-1.2.13-3.fc6
http://buildsys.fedoraproject.org/build-status/job.psp?uid=10527

See also ticket #185909 for the FC-5 branch update.

Note You need to log in before you can comment on or make changes to this bug.