Bug 167911 - $EDITOR should be set
$EDITOR should be set
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 10:23 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 05:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-09-09 10:23:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.5

Description of problem:
Users of Fedora miss out on one of bash's biggest time savers because $EDITOR is not set.

Say you're constructing a long command:

$ for i in *.c; do something $i; somethingelse $i; mv $i /path/to/somewhere^X^E
(Ctrl-X, Ctrl-E)

the shortcut to open your default editor will fail because EDITOR is not set.

I don't have emacs installed. It would be nice if vi loaded.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Bill Nottingham 2005-09-09 15:19:38 EDT
Hm, I'm not sure defaulting $EDITOR is really best. Perhaps bash should fall
back to _PATH_VI (from paths.h) if emacs isn't found.
Comment 2 Tim Waugh 2005-09-14 05:54:34 EDT
set -o vi
Then press 'v'
Comment 3 Need Real Name 2005-09-14 06:57:03 EDT
I don't want to change my line editing interface, I'm happy with the default -
but I do want to be able to use ^X^E without it falling over because it can't
use emacs.
Comment 4 Tim Waugh 2005-09-14 07:20:14 EDT
So you want to use emacs keybindings for command line editing, but vi
keybindings for editing the command line.  I suspect you are in the minority.

Please take this up with the bash maintainer if you'd like it changed.
Comment 5 Need Real Name 2005-09-14 07:57:21 EDT
Yes, why not? vi is the standard default editor, and bash - complete with emacs
keybindings - is the standard default shell.

I don't think the request is so strange.

Note You need to log in before you can comment on or make changes to this bug.