Bug 1679283 - newer 32-bit ARM processors missing from RPM detection/macros
Summary: newer 32-bit ARM processors missing from RPM detection/macros
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 30
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2019-02-20 19:26 UTC by Jeremy Linton
Modified: 2019-06-13 12:52 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-13 12:52:22 UTC


Attachments (Terms of Use)

Description Jeremy Linton 2019-02-20 19:26:09 UTC
Description of problem: It appears that the .rpm version being used in fedora is missing commits:

b1f81b837 Add armv8* arch variants to rpmrc.in and %arm macro
7f0e0b5be Fix %arm macro to include newer processor types
8c3a7b8fa Improve ARM detection

(due to them not being the in the latest release AFAIK)

This means that when run on a more recent processor (in a container) rpm fails to detect the platform correctly.

Version-Release number of selected component (if applicable): 4.14.2.1


Steps to Reproduce:
1. Running a 64-bit/aarch64 distro, install the 32-bit/armv7 container
2. note the platform name with uname
3. it should be something like `armv8l`
4. Attempt to build rpm's which have ${arm} macros


Actual results: The ${arm} sections are skipped


Expected results: The ${arm} sections are honored

Comment 1 Jeremy Linton 2019-02-20 19:31:00 UTC
Although possibly unrelated, it might be possible that this fixes the need to do `dnf --forcearch armv7hl` when running dnf in this enviroment too.

Comment 2 Panu Matilainen 2019-03-05 11:14:42 UTC
Moving to POST to indicate it's already fixed upstream.

Comment 3 Panu Matilainen 2019-06-13 12:52:22 UTC
Fixed in rawhide as of rpm >= 4.14.90.

This might get backported to older Fedoras in time.


Note You need to log in before you can comment on or make changes to this bug.