Bug 1679284 - [marketplace] updates from quay are not reflected for existing running operators
Summary: [marketplace] updates from quay are not reflected for existing running operators
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Kevin Rizza
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-20 19:39 UTC by aravindh
Modified: 2019-06-04 10:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:20 UTC

Description aravindh 2019-02-20 19:39:57 UTC
Given a cluster where an operator has been installed from OperatorHub. In that scenario, say the operator pod is restarted or the OperatorSource from where the operator was installed is deleted and during this time the operator was updated on Quay with a new version, it is observed that the existing Subscription does not show the update.

How reproducible: Always


Steps to Reproduce:
1. Install an operator from Quay
2. Remove the OperatorSource from where the operator was installed
3. Update the operator with a new version on Quay
4. Add the OperatorSource back

Actual results:
The Subscription object for the operator does not reflect the new version

Expected results:
The Subscription object should reflect the new version

Comment 1 Fan Jia 2019-03-12 02:02:24 UTC
test with the upstream image,and the function is ok now,will test when the new nightly payload is ok
marketplaceimage commit:5a98c3c3c3e3482b5507ffef2c73a59f703fc10b

Comment 4 errata-xmlrpc 2019-06-04 10:44:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.