Bug 1679300 - Unable to Change Host Location via Hammer
Summary: Unable to Change Host Location via Hammer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: 6.6.0
Assignee: Oleh Fedorenko
QA Contact: tstrych
URL:
Whiteboard:
: 1709253 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-20 20:37 UTC by kartik
Modified: 2019-11-21 19:17 UTC (History)
22 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-0.17.0.6-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 12:47:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 26536 Normal Closed Unable to Change Host Location via Hammer 2020-01-14 13:32:40 UTC
Red Hat Knowledge Base (Solution) 3935501 None None Changing Host Location via Hammer fails on Red Hat Satellite 6.4 2019-04-08 16:44:55 UTC
Red Hat Product Errata RHSA-2019:3172 None None None 2019-10-22 12:47:28 UTC

Description kartik 2019-02-20 20:37:52 UTC
Description of problem: Changing the Host location via Hammer fails with an error 
'Could not update the host: Resource host not found by id 'x''

Version-Release number of selected component (if applicable): 6.4


How reproducible:


Steps to Reproduce:
1.Get host-id, using # hammer host list
2.Get location-id, using # hammer location list
3. Change the host's location through hammer, using below command:

# hammer host update --id <host-id>  --location-id <>


Actual results: hammer host update fails with an error 'Could not update the host: Resource host not found by id 'x'


Expected results: To change the location of hosts using hammer host update


Additional info:

Comment 6 Oleh Fedorenko 2019-04-04 10:21:19 UTC
Created redmine issue https://projects.theforeman.org/issues/26536 from this bug

Comment 7 Bryan Kearney 2019-07-30 16:03:22 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/26536 has been resolved.

Comment 8 Oleh Fedorenko 2019-08-12 15:16:10 UTC
*** Bug 1709253 has been marked as a duplicate of this bug. ***

Comment 14 tstrych 2019-08-26 15:12:44 UTC
I reproduce the steps and hammer host update --id <id> --location-id <id> works only for location which is already assigned to host. 
When I use another location id I still get:
"""
Could not update the host:
  Resource host not found by id <host-id>
"""
Using sat 6.6 snap 17 with this package version: tfm-rubygem-hammer_cli_foreman-0.17.0.6-1.el7sat.noarch

Comment 15 Oleh Fedorenko 2019-08-27 13:07:35 UTC
This patch adds new options e.g. --new-location-id. If you want to update the location for a host, you should use hammer host update --id <host id> --location-id <loc id for scope> --new-location-id  <id of new location>.

Have you tried that?

Comment 16 Radovan Drazny 2019-09-04 15:47:16 UTC
I have tested changing the location using the --new-locatioin-id switch. This works, and I was able to change host's location . Satellitet 6.6 Snap 17, tfm-rubygem-hammer_cli_foreman-0.17.0.6-1.el7sat.noarch

$ hammer location list
---|------------------|------------------|------------
ID | TITLE            | NAME             | DESCRIPTION
---|------------------|------------------|------------
3  | AnotherLocation  | AnotherLocation  |            
2  | Default Location | Default Location |            
---|------------------|------------------|------------
$ hammer host info --id 3 | grep Location
Location:                 Default Location
$ hammer host update --id 3 --location-id 2 --new-location-id 3
Host updated.
$ hammer host info --id 3 | grep Location
Location:                 AnotherLocation

Comment 18 errata-xmlrpc 2019-10-22 12:47:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:3172


Note You need to log in before you can comment on or make changes to this bug.