Bug 167933 - RFE: net-snmp: don't remove the tkmib perl script
RFE: net-snmp: don't remove the tkmib perl script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
: Reopened
Depends On:
Blocks: 226192
  Show dependency treegraph
 
Reported: 2005-09-09 13:30 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 05:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2005-09-09 13:30:32 EDT
Description of problem:
The perl script tkmib is being deleted in the specfile.  Right is it
possible to include it in the binary RPMS as the perl Tk module
is available in Fedora Extras.  The script, if installed in its
default location may pull perl(TK::*) modules which may need to
be filtered.  An alternate solution would be to ship it as doc.


Version-Release number of selected component (if applicable):
net-snmp-5.2.1.2-2

  
Actual results:
The tkmib script is being deleted by the following line

   rm -f ${RPM_BUILD_ROOT}%{_bindir}/tkmib

in the specfile.


Expected results:
Ship the tkmib script in the net-snmp binary RPMS.


Additional info:
The perl Tk package is available in Fedora Extras for FC-3, FC-4, and devel.
Comment 1 Radek Vokal 2005-09-12 05:06:14 EDT
This can't be added into core package. The tkmib scripts need perl Tk module and
we can't require a package from extras to be installed for a core package. Would
be better to seperate a tkmib scripts from net-snmp and create new extras
package for it. 
Comment 2 Jose Pedro Oliveira 2005-09-12 10:28:37 EDT
Radek,

I re-opened this ticket because it can be done: you only need to filter the 
perl(Tk* requirements.  For a good example of filtering perl modules see the
samba package:

1) from the samba specfile

   ...
   # Don't depend on Net::LDAP
   Source999: filter-requires-samba.sh
   ...
   # Working around perl dependency problem from docs
   %define __perl_requires %{SOURCE999}
   ...

2) the samba filter script (SOURCE999)

   ----------
   #!/bin/sh

   /usr/lib/rpm/perl.req $* | grep -E -v '(Net::LDAP|Crypt::SmbHash|CGI)'
   ----------

/jpo
Comment 3 Red Hat Bugzilla 2007-02-05 14:33:05 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 4 Subhendu Ghosh 2007-03-14 15:29:01 EDT
With FC7 core and extras being merged - is this still an issue?
Comment 5 Jose Pedro Oliveira 2007-03-14 16:14:36 EDT
Yes.  There are several files being removed in the specfile  (one of them being
tkmib).


Net-snmp specfile
-----------------
...
rm -f ${RPM_BUILD_ROOT}%{_bindir}/snmpinform
rm -f ${RPM_BUILD_ROOT}%{_bindir}/tkmib
rm -f ${RPM_BUILD_ROOT}%{_bindir}/snmpcheck
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/snmpconf.1*
ln -s snmptrap ${RPM_BUILD_ROOT}/usr/bin/snmpinform
...

Comment 6 Jose Pedro Oliveira 2007-03-14 16:21:07 EDT
The tetex packager solved a problem similar to this one several years ago
(the texdoctk perl script).

See the following files in the tetex SRPM package:
  * tetex-3.0-tkdep.patch
  * tetex-filter-requires.sh

jpo
Comment 7 Jan Safranek 2007-10-25 05:22:53 EDT
If I add tkmib to net-snmp-perl, I must add dependency on perl-Tk. There is no
reason to hide the dependency, users expect that rpm resolves dependency
correctly so they do not need to take care after it.

And having net-snmp-perl dependent on perl-Tk is not something I'd like to have.
Net-snmp-perl should contain just perl bindings. I know, there is already mib2c
there, but it does not require any additional dependencies.

I created new package - net-snmp-gui, where you can find tkmib. Please check, if
it works and satisfies your needs (and there are no typos, I am not native
speaker :). It should land to rawhide soon (net-snmp-5.4.1-5.fc9).
Comment 8 Jan Safranek 2007-10-25 05:44:58 EDT
You can see the build at
http://koji.fedoraproject.org/packages/net-snmp/5.4.1/5.fc9/ until it gets
copied to rawhide mirrors.

Note You need to log in before you can comment on or make changes to this bug.