Bug 1679385 - Can't call method "sub_component_count happened while creating bug with non-exist component
Summary: Can't call method "sub_component_count happened while creating bug with non-e...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low with 1 vote vote
Target Milestone: 5.0-RH6
Assignee: Jeff Fearn 🐞
QA Contact: Lianghui Yu
URL:
Whiteboard:
: 1693158 1695642 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-21 03:24 UTC by Rony Gong πŸ”₯
Modified: 2019-08-13 18:37 UTC (History)
9 users (show)

Fixed In Version: 5.0.4-rh27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-08 14:20:51 UTC


Attachments (Terms of Use)

Description Rony Gong πŸ”₯ 2019-02-21 03:24:50 UTC
Description of problem:
Can't call method "sub_component_count happened while creating bug with non-exist component

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Try to create a Bugzilla bug by xmlrpc, but with a non-exist component
2.
3.

Actual results:
It returns
{'fault_code': -32000,
 'fault_string': 'Can\'t call method "sub_component_count" on an undefined value at /var/www/html/bugzilla/extensions/SubComponents/Extension.pm line 931.\n'}

Expected results:
{'fault_code': 51,
 'fault_string': "There is no component named 'bne-test' in the 'Bugzilla' product."}

Additional info:

Comment 1 Jeff Fearn 🐞 2019-03-27 10:14:47 UTC
*** Bug 1693158 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav SuchΓ½ 2019-04-11 11:54:22 UTC
This breaks ABRT reporting. Any reporting. From Fedora and from RHEL. It is very serious problem.

Comment 3 Lianghui Yu 2019-06-18 05:28:23 UTC
Happy to say this bug has been resolved on latest branch.
It is giving back right error message now.
Result: PASS

Comment 4 Jeff Fearn 🐞 2019-07-11 22:04:15 UTC
*** Bug 1695642 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Fearn 🐞 2019-08-06 00:29:43 UTC
This change has been staged on partner bugzilla. Feel free to test it there and let us know if you have any issues.

https://partner-bugzilla.redhat.com

Comment 7 Jeff Fearn 🐞 2019-08-08 14:20:51 UTC
This change is now live. If there are any issues, do not reopen this
bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.