Bug 167951 - Kernel error during yum update
Kernel error during yum update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 16:36 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 22:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-09-09 16:36:45 EDT
Description of problem:
The kernel kept throwing up a non-fatal error during a yum update (happened
about 7 times during the reading of the XML files)

Version-Release number of selected component (if applicable):
2.6.13-1.1542_FC5

How reproducible:
Very

Steps to Reproduce:
1. Drop to a console (ctrl-shift-f1)
2. Login as root (not su)
3. Run yum -y update
  
Actual results:
During the update the following occured a number of times

assertion ((int)tp->sacked_out >= 0) failed at net/ipv4/tcp_input.c (2147)

Expected results:
I shouldn't be getting the above!

Additional info:
Comment 1 Rahul Sundaram 2005-09-09 23:18:43 EDT
I cant reproduce this with today's rawhide. 
Comment 2 Paul F. Johnson 2005-09-10 03:30:54 EDT
Same here, but todays (2.6.13-1.1547_FC5) just kernel panics, so it can't be tested.
Comment 3 Dave Jones 2005-09-21 22:45:54 EDT
the tcp assertion should be fixed in latest builds.
Please file a separate bug for other problems.

Note You need to log in before you can comment on or make changes to this bug.