Bug 1679588 - openstack-nova-base-container includes bridge-utils due to os-vif dependency
Summary: openstack-nova-base-container includes bridge-utils due to os-vif dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-os-vif
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: Upstream M3
: 15.0 (Stein)
Assignee: smooney
QA Contact: Joe H. Rahme
URL:
Whiteboard:
Depends On:
Blocks: 1673612
TreeView+ depends on / blocked
 
Reported: 2019-02-21 13:36 UTC by Lee Yarwood
Modified: 2019-09-26 10:48 UTC (History)
12 users (show)

Fixed In Version: python-os-vif-1.15.1-0.20190307090256.4d95199.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of: 1673612
Environment:
Last Closed: 2019-09-21 11:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 636822 0 None master: MERGED os-vif: remove use of brctl from vif_plug_linux_bridge (Id03be72e22302a0954f3e47c116f389cb4304c03) 2019-03-05 11:10:37 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:55 UTC

Description Lee Yarwood 2019-02-21 13:36:14 UTC
This clone is being used to track the os-vif work to remove this dependency on bridge_utils:

brctl is obsolete use ip
https://bugs.launchpad.net/os-vif/+bug/1801919

+++ This bug was initially created as a clone of Bug #1673612 +++

Description of problem:

kolla specified bridge-utils for nova-base container.  That package is not available in RHEL 8.

Version-Release number of selected component (if applicable):


Actual results:

container can not build with bridge-utils included because it can not be found

Expected results:

template overrides to drop or explicit RFE to build bridge-utils in OSP 15


Additional info:

--- Additional comment from  on 2019-02-07 16:10:28 UTC ---

brctl is a hard dependency of os-vif for neutron networking with ml2/ovs and the iptables firewall driver.
https://github.com/openstack/os-vif/blob/master/vif_plug_ovs/linux_net.py#L103-L122
it is also a dependency for os-vif for linuxbridge.
https://github.com/openstack/os-vif/blob/master/vif_plug_linux_bridge/linux_net.py#L126-L128

additionally there are some code paths in nova related to nova networks that also use require brctl.

i have added os-vif to https://bugs.launchpad.net/os-vif/+bug/1801919
we have until feb 27th at the latest to fully remove the dependcy and relase os-vif
ideally we will try and complete this by febuary 22nd.

if it is not completed by the 27th we will need to package bridge-utils for rhel-8

Comment 1 smooney 2019-02-25 21:37:02 UTC
a quick update on this
https://review.openstack.org/#/q/status:merged+project:openstack/os-vif+branch:master+topic:bug/1801919
the upstream patches are merged and we will do a tommorow morning US time.

we had planned to do the release of os-vif today but we are holding for another 12-18 hours
to allow one more feature to land.

i have a upstream mail tread for the release of os-vif 
http://lists.openstack.org/pipermail/openstack-discuss/2019-February/003115.html
and ill will be updating it shortly stating which patch we are waiting.

Comment 2 smooney 2019-02-27 11:09:39 UTC
os-vif 1.15.0 has now been released without brctl requirement so we can proably remove the blocker flag.
https://pypi.org/project/os-vif/#history
the donwstream repo will need to be sync form upstream and the compose rebuilt.

Comment 6 smooney 2019-03-04 18:21:40 UTC
note we discoverd a minor bug in os-vif 1.15.0 and corrected it in os-vif 1.15.1 so os-vif 1.15.1 should be used as the min version for osp15

Comment 11 Joe H. Rahme 2019-08-06 15:53:31 UTC
This is covered by our standard regression testing.

Comment 15 errata-xmlrpc 2019-09-21 11:20:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.