Bug 1679619 - Undefined symbol in libfontconfig prevents any graphical activity (booting also).
Summary: Undefined symbol in libfontconfig prevents any graphical activity (booting al...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-21 15:14 UTC by Andrea Mastellone
Modified: 2019-02-22 12:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-22 12:14:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrea Mastellone 2019-02-21 15:14:43 UTC
Description of problem:

While booting the system, gdm-wayland-session complains undefined symbol FT_Done_MM_Var in libfontconfig, the same behaviour occurs issuing a startx from a textual console in a system started without graphical level.

Version-Release number of selected component (if applicable):
fontconfig-2.13.1-3.fc29.x86_64.rpm 

How reproducible:
Always.

Steps to Reproduce:
1. Boot the system with default settings.
2. 
3.

Actual results:

Booting hangs on a blank screen with a steady cursor.

Expected results:

Plymouth screen with fedora logo, then a X session.

Additional info:
I am providing journal and boot logs links on fedora paste:
https://paste.fedoraproject.org/paste/oWkRwE6zFksSwcw4RDPFSA

Comment 1 Akira TAGOH 2019-02-22 04:28:36 UTC
Apparently you had freetype-freeworld installed and it was replaced by freetype-2.9.1-6 which has Obsoletes line of it. This was caused by outdated freetype-freeworld package and isn't needed anymore because freetype has enabled ClearType thing by default now. this replacement should basically fixes your issue though, are you saying that you still see it even if you have freetype-2.9.1-6 installed?

Comment 2 Andrea Mastellone 2019-02-22 08:27:10 UTC
Yes, I think that something went messed up in the packages. Since this problem is specific to me only, I will change the severity to low. Now I will try a dnf reinstalling all packages, otherwise I'll do a clean installation.

Comment 3 Andrea Mastellone 2019-02-22 12:14:21 UTC
Solved by reinstalling F29.


Note You need to log in before you can comment on or make changes to this bug.