Bug 167965 - Fusion MPT SCSI driver LSI 22320-R
Fusion MPT SCSI driver LSI 22320-R
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 17:19 EDT by Brad Isbell
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Isbell 2005-09-09 17:19:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20041224

Description of problem:
We would like to make RedHat aware of an issue that we are able to consistently replicate in our lab environment.
We have already notified LSI Logic about a possible issue with their drivers.
Sun is aware of this problem and is currently working on finding a solution.
What we'd like to know from RedHat is- 'Why can we get a working solutions with RHEL U2, but the same procedures under RHEL U3 do not work?'

We have tried many combinations of RedHat updates/firwmware/drivers and have only found one workable solution.  The funny thing is that the workable solution is on an older update release of RHEL, and we have not been able to find a workable solution for RHEL U3 (we briefly worked with RHEL3 U4 without success, but U3 has been more thoroughly tested).
It seems to be a driver issue because we can see the LUN's correctly at the BIOS.

Equipment:
Dell PowerEdge 2800
LSI 22320-R PCI card  (LSI firmware on card: 01032700h   (1.03.27))
Sun StorEdge 3310 SCSI Disk Array (Configured with 3 LUN's)

-----------------------------
RHEL3 Update 2:
At initial install
Fusion MPT Drivers: 2.05.11.03
An /# fdisk -l/ or /#cat /proc/scsi/scsi/ shows 4 times as many LUN's (a total of 12) as are actually configured on our storage array.

Only after recompiling the kernel with the Fusion MPT Driver 2.06.18 does it work properly.
Using the rpm package to install the driver has an effect- we see 2 times as many LUN's as are actually configured on our storage array.


----------------------------
RHEL3 Update 3:
At initial install
Fusion MPT Drivers: 2.05.16
An /#fdisk -l/ or /#cat /proc/scsi/scsi/ shows only 1 LUN (LUN #0) from the storage array.
After updating the driver to 2.06.18, by rpm package or kernel rebuild, there is no change.  We still only see LUN 0.

----------------------------


H11S
Sun Heterogeneous Storage Support Team
Phone: 202-462-1599
Cell: 301-922-3571



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load RHEL U2 with LSI 22320-R SCSI HBA
2. Connect to Sun StorEdge 3310 array

Vs.
 
1. Load RHEL U3 with LSI 22320-R SCSI HBA
2. Connect to Sun StorEdge 3310 array

Both methods procude a problem, but the problems are different.  The problem with Update2 is fixable with the right Fusion MPT SCSI driver.  We have not found a solution to the problem with Update3 yet.

Actual Results:  With RHEL U2-
We see 4 times as many LUN's in an fdisk output than we should.  Until we put on the right driver, then it works.

With RHEL u3-
All we ever see is LUN 0 even when there are more LUN's that have been mapped to the SCSI channel.  Driver update does not fix.

Expected Results:  When the updated driver is installed on any of the update releases after U2 the problem should be fixed.

Additional info:

We are Sun's heterogeneous storage support team.  We handle all calls on behalf of Sun when one of their storage units is attached to any host running RedHat Linux, SUSE Linux, MS Windows, IBM AIX and HP-UX.
Sun sells RedHat Enterprise Linux as a supported OS with several of it's servers.  Sun OEM's LSI Logic's SCSI cards.
It would benefit all three companies- Sun, RedHat and LSI to find a solution to this problem.  We feel fairly certain the problem is with the driver from LSI Logic, but that does not explain why we can get RHEL3 U2 to work, but the later versions don't work.
Comment 1 Brad Isbell 2005-09-13 16:29:47 EDT
Have further tested RHEL U4 and have not been able to find a workable solution.
 It has the same problem that update 3 did- can only see LUN 0.
Comment 2 Tom Coughlan 2005-09-14 08:49:24 EDT
RHEL 3 will only scan past LUN 0 if you set the max_scsi_luns parameter. To do
this you must add the line "options scsi_mod max_scsi_luns=256" to
/etc/modules.conf, re-make the initrd, and reboot. 

After you do this, RHEL 3 probes the LUN space sequentially starting with LUN 0.
It stops when it finds a gap. The way to get it to scan past a gap is to add the
device to scsi_scan.c. I do not see the  Sun StorEdge 3310 listed there, but I
do see these, for example:

        {"SUN", "StorEdge 3510 ", "*", BLIST_SPARSELUN},
        {"SUN", "StorEdge 3511 ", "*", BLIST_SPARSELUN},

Are your LUNs numberred sequentially starting with LUN 0?

RHEL 4 uses the Report LUNs command, so it usually does not have these problems
if the device supports that SCSI command.

Does the storage device support the Report LUNs command?

Please post the messages in /var/log/messages that show up when you try to
configure this device.  
Comment 3 Brad Isbell 2005-09-15 10:11:37 EDT
Thank you very much.
Comment 4 Ernie Petrides 2005-09-15 16:07:02 EDT
Reverting to NEEDINFO.
Comment 6 RHEL Product and Program Management 2007-10-19 14:54:36 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.