Bug 1679782 - Inaccurate message when ssh into rhcos host
Summary: Inaccurate message when ssh into rhcos host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-21 20:42 UTC by Derek Carr
Modified: 2019-06-04 10:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:27 UTC

Description Derek Carr 2019-02-21 20:42:26 UTC
Description of problem:

ssh into rhcos reports the following message:

"In a future version of Red Hat CoreOS, this will cause nodes to become tainted."

This is not an agreed upon design direction.

I think the text should be updated as follows:

"The annotation 'machineconfiguration.openshift.io/ssh: accessed' has been applied to the node"


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Steve Milner 2019-02-21 21:30:50 UTC
Tested with 47.327

```
[bound] -bash-4.2$ ssh localhost
<snip />
WARNING: Direct SSH access to machines is not recommended.
This node has been annotated with machineconfiguration.openshift.io/ssh=accessed
```

I think the version you may have is pre the bugfix which fixed the message.

Jerry can you confirm?

Comment 2 Yu Qi Zhang 2019-02-21 21:48:15 UTC
Yes, the version with the fix is 47.323

The message was regressed briefly due to us switching around branches in our pipeline. This is fixed for versions 47.323 and later.

Comment 3 Micah Abbott 2019-02-25 15:37:51 UTC
Verified using 47.324

$ rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
● pivot://registry.svc.ci.openshift.org/rhcos/maipo@sha256:26dc9b8c8f65b1a76abe1614688f8dfa0eb42e861df019aa9825f8f12d62c43e
              CustomOrigin: Provisioned from oscontainer
                   Version: 47.324 (2019-02-20T17:18:30Z)

$ cat /etc/motd 
Red Hat CoreOS 4.0 Beta
WARNING: Direct SSH access to machines is not recommended.
This node has been annotated with machineconfiguration.openshift.io/ssh=accessed

---

Comment 5 errata-xmlrpc 2019-06-04 10:44:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.