Bug 167991 - RFE: Add consistency check for aliasing
RFE: Add consistency check for aliasing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2005-09-10 01:05 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-09-10 01:05:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
My wireless network interface ath0:1 is not started or shut down by the
network init script. Maybe it's because it contains a colon... my old ath0 
interface was started up just fine. This name was chosen by the system-config-network script.



Version-Release number of selected component (if applicable):
initscripts-8.12-3

How reproducible:
Always

Steps to Reproduce:
Reboot.

Additional info:
Comment 1 Bill Nottingham 2005-09-12 13:12:21 EDT
ath0:1 would be an alias device; that's not a primary interface name.

Assigning to system-config-network, but it looks like just a configuration error.
Comment 2 Ivan Gyurdiev 2005-09-12 16:14:05 EDT
Well, I think the way this happened was that I added a second interface for my
wireless card, before erasing the first one... then I erased the first one,
leaving myself in this situation. I suppose it's a rather dumb thing to do, and
maybe the bug should be closed.

On the other hand, the problem is that I didn't know this was an alias name -
there's nothing to indicate this - I shouldn't be expected to know the naming
patterns of Linux ethernet cards. On the other hand I do know that I set "Start
device on boot" to yes, and my device isn't being started. Perhaps UI design
should anticipate the user to do something dumb, and deal with it...

Note You need to log in before you can comment on or make changes to this bug.