Bug 168 - aic7xxx driver v5.1.4 defaults Extended Translation different...
aic7xxx driver v5.1.4 defaults Extended Translation different...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-23 07:57 EST by bmacy
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-08 13:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bmacy 1998-11-23 07:57:31 EST
The aic7xxx driver defaults to EXTEND_TRANS_[AB] being
enabled if a seeprom is not found. This causes a disk
partitioning scheme made with the v5.0.19 driver (shipped
with RedHat 5.1) to be invalid after an upgrade. This can
no be fixed using command-line args to the driver or any
BIOS settings. I got around it by making it default like
the driver I originally installed with. I can't see why
there is a valid reason to force Linux to use Translation
when it doesn't need it. Anyways, basically Redhat is
screwed now since they shipped a product that defaults the
other way... there is no way to make everyone happy.
Someone should add a "noextend" parameter for the driver.
Comment 1 motyl 1998-11-23 10:05:59 EST
I can confirm. It was introduced in 2.0.36pre14. The driver should
really be made to read the BIOS setting again.
I have reported it on 11 Nov 1998 on linux-kernel@vger..., as well as
to Alan and Doug.
Comment 2 Preston Brown 1998-11-23 11:42:59 EST
Doug, do you have anything to say about this one?
Comment 3 motyl 1998-11-25 15:48:59 EST
Easy way of getting system to boot again:
Having disk partitioned without extended translation, LILO install
in 2.0.36 kernel results in unbootable system.
But after enabling extended translation in BIOS the system boots
(fdisk is still confused though).
Comment 4 David Lawrence 1998-12-08 13:49:59 EST
Patch available
ftp.redhat.com/pub/aic/5.1.5/aic7xxx-5.1.5-2.0.36.patch.gz.  Fixes
this
problem.

Note You need to log in before you can comment on or make changes to this bug.