Bug 16800 - LPRng with remote Samba printers dies
LPRng with remote Samba printers dies
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Depends On:
  Show dependency treegraph
Reported: 2000-08-23 12:31 EDT by Adam Sleight
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-09 14:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Sleight 2000-08-23 12:31:27 EDT
works great when it works.  Printing to 8 different remote printers using 
Samba 2.07 on pinstripe.  smb.conf have map to guest = bad user for 
anonymous printing.  It seems to die every day or so.

killall -HUP smbd and killall -HUP nmbd seem to do the problem.  With 
Redhat 6.2 and samba 2.06 I seem to have no problems at all.


[2000/08/23 00:51:08, 0] lib/util_sock.c:write_socket_data(540)
  write_socket_data: write failure. Error = Broken pipe
[2000/08/23 00:51:08, 0] lib/util_sock.c:write_socket(566)
  write_socket: Error writing 4 bytes to socket 6: ERRNO = Broken pipe
[2000/08/23 00:51:08, 0] lib/util_sock.c:send_smb(754)
  Error writing 4 bytes to client. -1. Exiting
[2000/08/23 00:54:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'adams' in UNIX password database.
[2000/08/23 00:54:33, 1] smbd/service.c:make_connection(550)
  adams ( connect to service dp4hp as user nobody (uid=99, 
gid=99) (pid 1136)
[2000/08/23 00:58:33, 1] smbd/service.c:close_cnum(583)
  adams ( closed connection to service dp4hp
[2000/08/23 01:22:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'adams' in UNIX password database.


[root@localhost samba]# less smb.log
[2000/08/23 00:14:31, 1] lib/util_sock.c:client_name(1007)
  Gethostbyaddr failed for
[2000/08/23 00:14:31, 1] lib/util_sock.c:client_name(1007)
  Gethostbyaddr failed for
[2000/08/23 00:20:27, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 1014 are 
[2000/08/23 00:20:37, 1] lib/util_sock.c:client_name(1007)
  Gethostbyaddr failed for
[2000/08/23 00:20:42, 1] lib/util_sock.c:client_name(1007)
  Gethostbyaddr failed for
Comment 1 Tim Powers 2000-08-23 12:51:04 EDT
The default mapping (which is commented out) is guest = pcguest. If it is not
uncommented, and pcguest is not in /etc/passwd, the it defults to user "nobody". 

Is pcguest in /etc/passwd, and the mapping uncommented?

Comment 2 Adam Sleight 2000-08-23 13:37:44 EDT
The default mapping (which is commented out) is guest = pcguest

huh?  I've always used nobody..weird it works fine for awhile though.

guest account (S)

    This is a username which will be used for access to services which are 
specified as 'guest ok' (see below). Whatever privileges this user has will be 
available to any client connecting to the guest service. Typically this user 
will exist in the password file, but will not have a valid login. The user 
account "ftp" is often a ftp is a good choice for this parameter. If a username 
is specified in a given service, the specified username overrides this one. 

    One some systems the default guest account "nobody" may not be able to 
print. Use another account in this case. You should test this by trying to log 
in as your guest user (perhaps by using the "su -" command) and trying to print 
using the system print command such as lpr (1) or lp (1). 

    Default: specified at compile time, usually "nobody" 

so samba 2.07 is compiled for pcguest?  So why does it work for about 2 days 
and then die?  Is this the reason?  I've been running it for about 2 weeks now 
and it works fine for about a day or 2 days then dies.

Ok I'll try your suggestion and put pcguest in /etc/passwd and change guest 
account from nobody to pcguest.
Comment 3 Tim Powers 2000-08-23 13:51:05 EDT
That was just from a cursury look at the config file shipping in samba-common
now. I'm still invesigating this.

Comment 4 Nalin Dahyabhai 2000-08-23 14:57:09 EDT
Have you configured any naming services other than the defaults in
/etc/nsswitch.conf?  I ask because of the error looking up the user "adams" that
the server is loggin would indicate some problem there.
Comment 5 Adam Sleight 2001-05-09 00:40:15 EDT
no I did not.  All I can say is we've been using e-smith.com distro for 
anonymous printing for the last 5 months or so and it's never froze once unlike 
redhat was doing.  E-smith is based on RH 7.0 with minor modifications so it 
makes me wonder.  Haven't tried it with RH 7.1 to see if this is "fixed" yet 
adams is "me" and I don't believe I added myself to the server.  No one else 
could print either.  Tried on 5 or so other computers.  With e-smith we have 
80+ users printing anonymously and none of them have an account on the print 
Comment 6 Trond Eivind Glomsrxd 2001-06-20 15:49:33 EDT
The original report wasn't on pinstripe... is this still a problem with a newer
version of Red Hat Linux (7 or 7.1) with all errata (lprng and samba,
especially) applied?
Comment 7 Trond Eivind Glomsrxd 2001-08-09 14:16:48 EDT
Comment 8 Trond Eivind Glomsrxd 2001-11-29 12:16:03 EST
Closing due to lack of feedback - it's known to work in newer releases, at the

Note You need to log in before you can comment on or make changes to this bug.