Bug 168010 - /etc/profile.d/vim.sh don't applies to root user
/etc/profile.d/vim.sh don't applies to root user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-10 13:45 EDT by Sergio Monteiro Basto
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 05:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my propose patch (439 bytes, patch)
2005-09-10 13:45 EDT, Sergio Monteiro Basto
no flags Details | Diff

  None (edit)
Description Sergio Monteiro Basto 2005-09-10 13:45:02 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install vim-enhanced
2.Log in and type 'alias'  Note that 'vi' is aliased to 'vim' correctly.
3.su -
4.as root user edit some .spec file
  
Actual results: vi was not aliased to vim and text isn't color coded


Expected results: vi should be aliased to vim and text is color coded


Additional info:
Comment 1 Sergio Monteiro Basto 2005-09-10 13:45:02 EDT
Created attachment 118680 [details]
my propose patch
Comment 2 Karsten Hopp 2005-09-12 05:00:13 EDT
using /bin/vi for users with UID < 100 including UID 0 is intentional and was
made by the request of many users. /usr/bin/vim won't work for sysadmins on many
cases, p.e. if /usr isn't mounted or is mounted via NFS and the NFS server is down.
/bin/vi will still work in those cases.
Comment 3 Sergio Monteiro Basto 2005-09-13 21:10:03 EDT
Sorry can't agree it that, because those are 1% of cases and those users should
use /bin/vi like you write.
The others 99% are losing the benefits of vim.
Comment 4 Karsten Hopp 2005-09-14 04:54:26 EDT
Well, lets try another reasoning:
when root types 'vi', he will get a editor as it is defined in the POSIX standard.
'vim' on the other hand isn'T POSIX compatible.

Note You need to log in before you can comment on or make changes to this bug.