Bug 168020 - rc.sysinit loads rivafb module, breaking external display on notebooks with nvidia video cards
rc.sysinit loads rivafb module, breaking external display on notebooks with n...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-09-10 17:25 EDT by Alexandre Oliva
Modified: 2014-03-16 22:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 17:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for this (672 bytes, patch)
2005-09-12 17:23 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2005-09-10 17:25:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
/sbin/kmodule now prints VIDEO rivafb on boxes that have nvidia video cards, so rc.sysinit loads this module.  This has the following bad effects:

- the box freezes when rhgb completes and gdm starts, or when one gdm session completes and another is about to start

- it's impossible to switch to the external display on notebooks (an i686 with GeForce2 Go and an Athlon 64 with GeForce4 440 Go), a documented feature of the rivafb module

- on the i686 notebook, closing the lid corrupts the running X session, and makes text mode totally unusable

This is a major regression from FC4, as well as rawhide as of Sept 8, 2005.  rivafb should not be loaded unless the user really means to load it.

Version-Release number of selected component (if applicable):
initscripts-8.13-1

How reproducible:
Always

Steps to Reproduce:
1.Boot up a notebook with a GeForce*Go video card
2.Try to use an external display connected to it

Actual Results:  It doesn't work at all.  If rhgb is enabled, not even the internal display will work, since the box will freeze when rhgb completes.  Text mode will be unusable as soon as you try to switch to the external display (or, worse, if the external display is chosen by default).

Expected Results:  rivafb should not be loaded, since it has a number of undesirable consequences, and some of them are actually features.

Additional info:

aliasing rivafb to video in /etc/modprobe.conf works around the problems and brings the notebooks back to a functional state.
Comment 1 Alexandre Oliva 2005-09-11 20:54:07 EDT
FWIW, this also killed my 3 desktop boxes with Nvidia TNT2 video cards.  Like
the others, they'd freeze when rhgb hands off VT8 and gdm tries to start a
session in VT7.  This obviously means rivafb is pretty buggy, and had better be
avoided for now.  Sure enough, as soon as this major bug in it is fixed, it
could become usable for single-headed desktops, but would still kill notebooks
that want to switch between internal and external display.  If it wasn't enough
that the `nv' driver in X is too dumb to handle switches between displays,
requiring a full restart of the X session, rivafb actually makes it totally
impossible to work, by setting up the display such that only the LCD display
works if it's detected.
Comment 2 Bill Nottingham 2005-09-12 17:23:54 EDT
Created attachment 118742 [details]
Patch for this

Here's the patch for this. It will be in 8.14-1.
Comment 3 G.Wolfe Woodbury 2005-09-12 19:57:51 EDT
see also 168054 for other comments

Note You need to log in before you can comment on or make changes to this bug.