Bug 168026 - kernel panic on boot with kernel-smp-2.6.13-1.1547_FC5
kernel panic on boot with kernel-smp-2.6.13-1.1547_FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-10 21:37 EDT by Jef Spaleta
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 22:09:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of kernel panic on boot (846.86 KB, image/jpeg)
2005-09-10 21:37 EDT, Jef Spaleta
no flags Details
boot with vga=791 (588.61 KB, image/jpeg)
2005-09-12 00:02 EDT, Jef Spaleta
no flags Details
Top portion of screen for kernel-smp-2.6.13-1.1553_FC5 panic (830.14 KB, image/jpeg)
2005-09-14 19:19 EDT, Jef Spaleta
no flags Details
Bottom portion of screen during kernel-smp-2.6.13-1.1553_FC5 panic (858.00 KB, image/jpeg)
2005-09-14 19:21 EDT, Jef Spaleta
no flags Details

  None (edit)
Description Jef Spaleta 2005-09-10 21:37:25 EDT
Description of problem:
panic on boot.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.13-1.1547_FC5 doesn't boot
kernel-smp-2.6.13-1.1542_FC5 boots

How reproducible:
everytime


Additional info:
Attached is a screenshot of the panic message

Please let me know if you need any additional information
Comment 1 Jef Spaleta 2005-09-10 21:37:26 EDT
Created attachment 118686 [details]
screenshot of kernel panic on boot
Comment 2 Dave Jones 2005-09-11 23:09:17 EDT
can you boot with vga=791 and try again. This will get more lines of text on the
console, so we can see the top of that message.
Comment 3 Jef Spaleta 2005-09-12 00:02:47 EDT
Created attachment 118703 [details]
boot with vga=791

my camera doesn't seem to want to focus very well on the monitor.  If this
isn't legible I can try again tomorrow night.
Comment 4 Dave Jones 2005-09-12 01:20:27 EDT
hmm, can just about make out 5a5a5a5a in the registers, which is using memory
after its been freed. There was a bug fixed today in the IO scheduler that may
be the cause of this. You can try booting with a different one (boot with
elevator=as to try this).

That fix got checked in this afternoon, so will end up in tomorrows -git tree,
and thus, Tuesdays rawhide kernel.

If this is a different bug, a better screen shot would be appreciated :)

Thanks.
Comment 5 Jef Spaleta 2005-09-12 19:48:19 EDT
booting with elevator=as  didnt help at all... it was a different traceback.

I'm going to have to try to get some different lighting at the moniter the
autofocus isnt working very well. I can't get anything readable with the camera
at the moment.  I'll try to get a better image and report back.

-jef
Comment 6 Jef Spaleta 2005-09-14 19:16:12 EDT
Still getting panics...even with kernel-smp-2.6.13-1.1553_FC5 from today's
rawhide. The panic is happening right after the
"Initializing hardware... " messages about ide scsi network audio other

I'm going to try my best to get better digital shots of the panic...stay tuned.

-jef
Comment 7 Jef Spaleta 2005-09-14 19:19:35 EDT
Created attachment 118822 [details]
Top portion of screen for kernel-smp-2.6.13-1.1553_FC5 panic

stupid digital camera... i think i can do a little better if i try to do part
of the screen at a time. This is the top half.
Comment 8 Jef Spaleta 2005-09-14 19:21:39 EDT
Created attachment 118823 [details]
Bottom portion of screen during kernel-smp-2.6.13-1.1553_FC5 panic

I hope these 2 screen portions are better

-jef
Comment 9 Jef Spaleta 2005-09-20 19:58:14 EDT
I think i have made some progress with this.
I am able to boot using "nousb" as a boot time parameter.
Now that I can get the kernel to boot, I'm going to spend some boot cycles
trying to see if i can narrow it down to a specific usb device or driver.

Any suggestions off the top of your head?

my modprobe.conf has
alias usb-controller ohci-hcd
alias usb-controller1 ehci-hcd

-jef
Comment 10 Jef Spaleta 2005-09-20 20:59:40 EDT
ah.. more progress.
I have narrowed the kernel panic down to my microtek slimscan c6 usb scanner
which uses the microtek kernel module.  

kernel-smp-2.6.13-1.1561_FC5 boots fine if that usb device is not plugged in.
And then repeatable panics if i plugin the scanner at any point before or after
booting up.

Is there any specific logging you would like me to provide?
the last kernel to successfully work with this scanner was 
kernel-smp-2.6.13-1.1542_FC5. I could boot into that 1542 kernel and give you
information with the device logged in. I'm just not sure what information would
be useful.

-jef
Comment 11 Dave Jones 2005-10-06 02:45:07 EDT
is this still happening ?
Comment 12 Jef Spaleta 2005-10-06 08:13:43 EDT
First chance to test this with the latest rawhide kernel will be tonight
~14hours or so from now I'll report back this evening or tomorrow morning.

-jef
Comment 13 Jef Spaleta 2005-10-07 01:03:08 EDT
kernel 2.6.13-1.1597_FC5smp  still has a kernel panic when i plug my usb scanner
in and the microtek kernel module is loaded.

-jef
Comment 14 Dave Jones 2005-11-04 16:14:28 EST
has this got any better ?
The puzzling thing is, during the window of works/dont-work kernels, there were
only some really benign changes to the microtek driver. So this may be
introduced through changes elsewhere.
Comment 15 Jef Spaleta 2005-11-06 17:48:51 EST
No not any better. 
Every kernel i've booted all the way through
2.6.14-1.1642_FC5smp has kernel panic when i plug in this usb scanner of if the
scanner is plugged in at boot.

-jef


Comment 16 Jef Spaleta 2005-11-15 20:10:15 EST
Just a heads up, 2.6.14-1.1674_FC5smp  still has the kernel panic behavior with
the microtek sub scanner.

i was sort of hoping usb_hfc was going to be magically responsible for this too,
but alas I am not so lucky.

-jef
Comment 17 Jef Spaleta 2005-11-29 22:09:02 EST
2.6.14-1.1720_FC5smp seems to be the magic bullet for all my problems.

the microtek module is now loading and the scanner actually seems to work again.

I'm closing this bug out as resolved.

Note You need to log in before you can comment on or make changes to this bug.